Problem installing device driver for FTDI Chip, please help!

Having trouble running Advanced Installer? Got a bug to report? Post it all here.

Problem installing device driver for FTDI Chip, please help!

Postby dreyfus » Wed Feb 02, 2011 2:35 pm

Hi!
I'm Viorel from Romania.
I need desperately to deploy an application in order to be used in conjunction with GPO to be installed on about 300 Windows XP clients.
It consists in an application and a driver.
I can't manage to make the drivers install. I have 2 infs for the drivers. It's a FTDI driver, a microcontroller chip.
One is ftdibus.inf and the other one is ftdiport.inf.
I've just tried to add on the driver page the inf files (the rest of the driver files where on their relative paths).
Tried to swith the 2 different drivers using the 'Move Up' from the context-sensitive menu. Each time I've build the pachage and tried to deply but no success.
What is happening is that when I plug in the device (that happens if the device is already attached) it just says found new hardware and the "Add new hardware" wizzard pop-up. Just that.
If I go to the add/remove applet the driver is listed there but it's not installed actually.
I have to do something with the GUID? or something?

Also, those drivers need to be installed without the user action (users on machines do not have admin priviledges)
If you can help me, I will send the drivers and application files zipped and if you could complile the .msi file for me.
Please! I'm trying to solve that problem for some months.

my yahoo id is viorelianasi (if you have time to chat about that)

following some captures:




Image
Image
Image
Image
Image
dreyfus
 
Posts: 2
Joined: Wed Feb 02, 2011 12:02 am

Re: Problem installing device driver for FTDI Chip, please help!

Postby octavian.vasilovici » Wed Feb 02, 2011 3:27 pm

Hello Viorel and welcome to Advanced Installer forums,

Unfortunately, Advanced Installer doesn't support installing Hardware First Install type drivers. It was designed for Software First Install drivers only that usually come with your application, e.g. an anti-virus filter for the network adapter.

The possible solution for your problem would be this:
- Add the driver files in Files and Folders Page in the location where you want to copy them (the location where they should be once they are integrated in Windows OS).
- Research on how to integrate your drivers in Windows and create a script file if needed (like a bat file). A good starting point would be to manually install the driver and see where each file is copied. Also MSDN.com can provide information on this topic.
- Add this script file as a Custom Action after "InstallExecute" Standard Action.
This way the files will be copied in their location and after the batch file will run and integrate the drivers in Windows OS.

Hope this helps. If you have any other questions, please don't hesitate to contact us.

Best Regards,
Octavian
_______________________________________________________________________________________________________________________________________________
Octavian Vasilovici
Advanced Installer Team
http://www.advancedinstaller.com/
octavian.vasilovici
 
Posts: 51
Joined: Tue Jan 25, 2011 2:43 pm

Re: Problem installing device driver for FTDI Chip, please help!

Postby dreyfus » Wed Feb 02, 2011 4:33 pm

The drivers can be installed at any time.
I just wanna say that someone made a .msi file that have thouse drivers integrated and the same application as well, using Advanced Installer 8.02 but at that time the drivers were not signed and at the install time required the user interaction to contrinue installing the usigned drivers.
So it seems that it can be done by using this tool.
dreyfus
 
Posts: 2
Joined: Wed Feb 02, 2011 12:02 am

Re: Problem installing device driver for FTDI Chip, please help!

Postby patku » Fri Apr 29, 2011 10:11 pm

Advanced Installer doesn't support installing Hardware First Install type drivers. It was designed for Software First Install drivers only that usually come with your application

Could you please clarify that statement?

I've created MSI packages that install drivers before (see http://stackoverflow.com/questions/2776 ... ger-prompt), but it's a bit of a pain. I was under the impression that this is possible with Advanced Installer, but @octavian.valiovici's response seems to indicate that is not the case (or there is some confusion about what is possible).

AI employees, please clarify the limitations of driver installations with AI.
Thanks,
Pat
patku
 
Posts: 4
Joined: Fri Apr 29, 2011 10:04 pm

Re: Problem installing device driver for FTDI Chip, please help!

Postby mihai.petcu » Mon May 02, 2011 1:08 pm

Hello Pat,

My colleague's statement is correct, however there might be some hardware drivers that work with DIFx as well( like the one you successfully installed ), but this is not a general rule.

Here is another thread which should clarify this.

All the best,
Mihai
Mihai Petcu
Advanced Installer Team
http://www.advancedinstaller.com/
mihai.petcu
 
Posts: 3572
Joined: Thu Aug 05, 2010 8:01 am


Return to Common Problems

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 11 guests