Search found 110 matches

Go to advanced search

by Antarctica
Tue Dec 04, 2018 2:25 pm
Forum: Common Problems
Topic: IIS configuration and Windows feature configuration slow on Server 2008
Replies: 1
Views: 1215

IIS configuration and Windows feature configuration slow on Server 2008

On Windows Server 2008, the windows features configuration is really slow; it takes 10 minutes or even more. The same Windows features are configured in under a minute on Windows Server 2012 and 2016. Is this an issue with the Windows version or may there be a problem in Advanced installer? It seems...
by Antarctica
Wed Oct 17, 2018 3:56 pm
Forum: Common Problems
Topic: Weird bloat in my AIP file
Replies: 4
Views: 1943

Re: Weird bloat in my AIP file

Thank you for the notification; but a few days ago I have been notified by AI support that AIP files have to be committed to git as a binary files because auto-merge can destroy AI projects, so my bug report was already obsolete.
by Antarctica
Mon Oct 15, 2018 3:41 pm
Forum: Common Problems
Topic: Custom control in Advanced Installer dialog
Replies: 1
Views: 1104

Custom control in Advanced Installer dialog

I would like to add a custom WinForms component (based on a DataGrid) to an Advanced Installer dialog. I found that I can open a sub-window from a dialog, but can I either replace your dialog with my own or add the control to your dialog?
by Antarctica
Thu Oct 11, 2018 4:22 pm
Forum: Common Problems
Topic: Merge conflict after two people added files to installer.
Replies: 1
Views: 1099

Merge conflict after two people added files to installer.

When files(?) are added to the installer independently by two developers, the row <ROW Feature="MainFeature" Title="MainFeature" ... is updated to reflect the changed values. This causes a merge nightmare in git, since we have are one hundred and eighty values in the main feature, and all of them in...
by Antarctica
Wed Sep 19, 2018 12:22 pm
Forum: Common Problems
Topic: Weird bloat in my AIP file
Replies: 4
Views: 1943

Weird bloat in my AIP file

Using git diff on my AIP for the first time, I found that some parts are added over and over again with incrementing numbers: <COMPONENT cid="caphyon.advinst.msicomp.AiPersistentPropComponent"> <ROW Property="DISPATCHER" Registry="DISPATCHER" HklmSearch="DISPATCHER" HkcuSearch="DISPATCHER_1" Hklm64S...
by Antarctica
Wed Aug 22, 2018 3:01 pm
Forum: Common Problems
Topic: Advanced Installer 15.2 regression bug: Custom Action "Hide program window"
Replies: 17
Views: 5858

Advanced Installer 15.2 regression bug: Custom Action "Hide program window"

I am executing two shell program calls, and I am executing them in the background:

Image

This worked with installers built in Advanced Installer 15.1.

However, in Advanced Installer 15.2, they are no longer hidden:

Image
by Antarctica
Mon Aug 20, 2018 2:34 pm
Forum: Common Problems
Topic: SQL Server is TLS 1.2 only - ODBC connection timeout
Replies: 9
Views: 22193

SQL Server is TLS 1.2 only - ODBC connection timeout

Hello Advanced Installer team, TLS 1.0 is deprecated since June 30, 2018, and use of TLS 1.2 is strongly encouraged. Eventually, some customers have started to switch to TLS 1.2 only. I am using ODBC Connection Test in an installer built with AI 15.1. When the SQL server's SCHANNEL.DLL is configured...
by Antarctica
Fri Aug 10, 2018 3:51 pm
Forum: Common Problems
Topic: Controls toolbox not showing
Replies: 9
Views: 3422

Re: Controls toolbox not showing

I thought hard about it and I can finally cause the issue reproducibly. I am sometimes switching between two desks, and for some reason the monitors are attached differently on different desks, so I head into View Options and drop monitor 2 to the right or left side of monitor 1, to match the actual...
by Antarctica
Wed Aug 08, 2018 9:15 am
Forum: Common Problems
Topic: Controls toolbox not showing
Replies: 9
Views: 3422

Re: Controls toolbox not showing

I always had a two-monitor setup on this machine - never one, never three. Always the same two Full-HD displays. Not sure how the toolbox got into that ffff... position.
by Antarctica
Tue Aug 07, 2018 3:56 pm
Forum: Common Problems
Topic: Controls toolbox not showing
Replies: 9
Views: 3422

Re: Controls toolbox not showing

I just found in the registry at Computer\HKEY_CURRENT_USER\Software\Caphyon\Advanced Installer\UI Positions\Dialogs\Dialog Editor\Toolbox PositionX the value fffffa5e I have reset the value to 100, and the toolbox was visible again. Then I tried the visible values: When the window is in the top left...
by Antarctica
Tue Aug 07, 2018 3:49 pm
Forum: Common Problems
Topic: Controls toolbox not showing
Replies: 9
Views: 3422

Re: Controls toolbox not showing

My OS is Windows 10 as well. Is it possible that the window position of the toolbox is saved somewhere and is outside the visible area?
by Antarctica
Tue Jul 17, 2018 8:56 am
Forum: Common Problems
Topic: Controls toolbox not showing
Replies: 9
Views: 3422

Controls toolbox not showing

The controls toolbox is no longer showing anywhere. I can click it on or off from the toolbar, it is not rendered anywhere on any of my two screens.
I have already tried updating AI, but this behaviour is consistent is in 14.5.2, 14.8 and 15.0.1.
by Antarctica
Fri Jul 13, 2018 11:47 am
Forum: Common Problems
Topic: Installer does not execute Custom Action on Uninstall
Replies: 5
Views: 2108

Re: Installer does not execute Custom Action on Uninstall

Hello Eusebiu, yes, you are right - one issue seems to be that some searches have to be executed before, and others can only be executed after the custom action has been executed. Correct order: - Registry Search for APPDIR - CheckWebConfig CA - DecryptAppSettings CA - XML Search for TESTPROPERTY Bu...
by Antarctica
Wed Jul 11, 2018 6:02 pm
Forum: Common Problems
Topic: Installer does not execute Custom Action on Uninstall
Replies: 5
Views: 2108

Re: Installer does not execute Custom Action on Uninstall

Hello Eusebiu, I finally found the time to come back to this issue. I did not find how to tell Advanced Installer to make me a verbose uninstall log. A relevant post I found does not tell me where to find that shortcut. However, I have created a bare aip file for you, see attached. The installer you...
by Antarctica
Fri Jun 08, 2018 9:40 am
Forum: Common Problems
Topic: Text is not transparent
Replies: 1
Views: 1098

Text is not transparent

Some text in my installer has gray background:
Image
In AI 14.5.2, however, "Transparent" is true:
Image
Also, "Limit to Basic UI" is not selected:
Image

What is the issue here?

Go to advanced search