Search found 18 matches

Go to advanced search

by jstart
Thu Feb 20, 2020 3:27 pm
Forum: Common Problems
Topic: Service Account Password variable replaced during AI upgrade
Replies: 5
Views: 3875
 
Jump to post

Re: Service Account Password variable replaced during AI upgrade

Hi Eusebiu, Thanks for getting back to me. I've re-added the property (by copy & paste) to the service account password and it is all working now. :D It did NOT have the "Secure property" option set for it in the "Install Parameters" page. A suggestion to enhance the AI GUI w...
by jstart
Tue Feb 18, 2020 4:49 pm
Forum: Common Problems
Topic: Service Account Password variable replaced during AI upgrade
Replies: 5
Views: 3875
 
Jump to post

Re: Service Account Password variable replaced during AI upgrade

Hi Eusebiu. Thanks for the reply. I've confirmed that [SERVICE_PASSWORD] and [SERVICE_USER] have the correct values set, by displaying them in a edit box on the next installer dialog AND from the MSI verbose installer log: MSI (c) (20:70) [15:14:52:762]: PROPERTY CHANGE: Modifying SERVICE_PASSWORD p...
by jstart
Tue Feb 18, 2020 10:43 am
Forum: Common Problems
Topic: Service Account Password variable replaced during AI upgrade
Replies: 5
Views: 3875
 
Jump to post

Service Account Password variable replaced during AI upgrade

Hi, This is a copy of a support email I originally sent on 12/02/2020 and 14/02/2020, but have not yet had a reply: We have an installer project that adds our service with the credentials supplied during install time. This used to work, however since upgrading the AIP from v13.6 to v14.9 it has ceas...
by jstart
Wed Feb 22, 2017 5:47 pm
Forum: Common Problems
Topic: signing MSI takes VERY long time ...
Replies: 5
Views: 7824
 
Jump to post

Re: signing MSI takes VERY long time ...

Hi,
I've noticed this issue since upgrading from AI v12.3.1 to v13.6.
It appears that the install of the latest version of AI (side by side with an older version) does not set the External Signing tool - it needs to be explicitly set, as mentioned above.
J.
by jstart
Wed Feb 22, 2017 5:35 pm
Forum: Common Problems
Topic: Upgrading AI v12.3 to v13.6 loses Customizable Images
Replies: 1
Views: 1743
 
Jump to post

Upgrading AI v12.3 to v13.6 loses Customizable Images

Hi, I’m in the process of upgrading our AI projects from v12.3.1 to v13.6. I’ve noticed that some AI configuration and customisation seems to get lost, such as: 1) "Never Use Enhanced User Interface" (Themes|Settings|User Interface|Use Enhanced User Interface|Never) - this had changed to &...
by jstart
Wed Nov 23, 2016 5:18 pm
Forum: Common Problems
Topic: Windows installer crash
Replies: 5
Views: 7700
 
Jump to post

Re: Windows installer crash

Hi TheBeardedDev - here is my private email conversation with AI, most recent at the top: Hello James, This seems to be an Advanced Installer issue related with our service failure operation support. We'll try to fix this in a future version of AI, but I'm afraid I cannot give you any ETA for the fi...
by jstart
Thu Oct 06, 2016 10:52 am
Forum: Common Problems
Topic: Documentation - Uninstall Rollback missing from User Guide
Replies: 1
Views: 1890
 
Jump to post

Documentation - Uninstall Rollback missing from User Guide

Hi,
Ref: http://www.advancedinstaller.com/user-g ... tions.html
It would appear after discussion with Eusebiu that the 'uninstall rollback' case is missing from the online user guide.
Please could you update the documentation to cover this scenario.
Thanks,
James.
by jstart
Tue Aug 30, 2016 4:03 pm
Forum: Building Installers
Topic: Uninstall Rollback – is it possible?
Replies: 1
Views: 2085
 
Jump to post

Uninstall Rollback – is it possible?

I’m trying to improve the robustness of our installer which adds our Transport Agent (C# DLL) and registers it with Exchange 2013/16 using Exchange Power Shell. This process is slow, it can take 5-10secs to load ExPS and allows plenty of time for the user to cancel the install / uninstall. Initially...
by jstart
Mon Apr 04, 2016 4:00 pm
Forum: Common Problems
Topic: Crash seen in MMC if snap-in in use during uninstall
Replies: 6
Views: 10796
 
Jump to post

Re: Crash seen in MMC if snap-in in use during uninstall

Hi, I’ve tried your suggestion – my implementation pops up a message box telling the user to close a list of mmc(s) that have our snap-in loaded. This works to a degree, the issue comes in the following scenario: 1) Install our product. 2) Run mmc (64bit) and add any snap-in (e.g. DNS) + Our snap-in...
by jstart
Wed Mar 30, 2016 11:11 am
Forum: Common Problems
Topic: Windows installer crash
Replies: 5
Views: 7700
 
Jump to post

Windows installer crash

Advanced Installer v12.3.1. Source code: .NET4, VS2010 SP1, compiled as x64. Target: Windows 2012 R2 (no updates) and Exchange 2013 CU5. I'm trying to see if I can get a repro with a simple installer package, rather than sending our complete product which will require Exchange 2013 CU5 and AD Schema...
by jstart
Fri Mar 18, 2016 5:30 pm
Forum: Common Problems
Topic: Crash seen in MMC if snap-in in use during uninstall
Replies: 6
Views: 10796
 
Jump to post

Re: Crash seen in MMC if snap-in in use during uninstall

Hi Daniel, Thanks for the reply. Please confirm which server you tested it on, as you mention "Windows Server 2002 R2". The issue doesn't always happen (1:2), but we've seen it on several (5+) Windows Server 2012 R2 virtual machines and Windows 2008 R2 - these are different machines belong...
by jstart
Fri Mar 18, 2016 3:23 pm
Forum: Common Problems
Topic: Crash seen in MMC if snap-in in use during uninstall
Replies: 6
Views: 10796
 
Jump to post

Re: Crash seen in MMC if snap-in in use during uninstall

**** Further update: **** I can repro this using a simple C++ ATL sample SnapIn (32bit) and a new AI installer that registers the DLL. Similar event log and problem signatures as before: Faulting application name: mmc.exe, version: 6.3.9600.16384, time stamp: 0x52158765 Faulting module name: DUser.d...
by jstart
Thu Mar 17, 2016 1:07 pm
Forum: Common Problems
Topic: Crash seen in MMC if snap-in in use during uninstall
Replies: 6
Views: 10796
 
Jump to post

Crash seen in MMC if snap-in in use during uninstall

**** UPDATED: attached incorrect AI project file, should be "Test Application 2.aip" **** One of our server products crashes most of the time during uninstall if our MMC SnapIn is in use during the uninstall after trying to automatically close the application. I’ve been able to repro the i...
by jstart
Tue Dec 22, 2015 3:38 pm
Forum: Common Problems
Topic: Service Failure Operation with Custom Setups
Replies: 2
Views: 2249
 
Jump to post

Re: Service Failure Operation with Custom Setups

It looks like this issue doesn't repro with AI v12.0 (trial license).
by jstart
Tue Dec 22, 2015 12:46 pm
Forum: Common Problems
Topic: Service Failure Operation with Custom Setups
Replies: 2
Views: 2249
 
Jump to post

Service Failure Operation with Custom Setups

Hi, I'm using Advanced Installer v11.4.1, my source binaries are x64, .NET3.5, VS2010. Target OS: Windows 2008 R2. I can create an AI project to install two features, a simple exe and a service. For the service I've configured a Control Operation and a Failure Operation, containing 3x Failure Action...

Go to advanced search