Search found 4330 matches

Go to advanced search

by Catalin
Fri Sep 17, 2021 6:05 pm
Forum: Building Installers
Topic: Delete .exe install
Replies: 4
Views: 101

Re: Delete .exe install

Hello, That message is usually displayed when two products having the same ProductCode are installed on the same machine. Please have a look over the following forum thread which discusses the same issue: Another version of this product is already installed (EXE file) Basically, you need to make sur...
by Catalin
Fri Sep 17, 2021 5:28 pm
Forum: Building Installers
Topic: Create EXE and launch from installer.
Replies: 3
Views: 1556

Re: Create EXE and launch from installer.

Hello Prashanth, Yes, it is possible to do that. There are actually two ways of achieving this: 1. you could add the .EXE as a prerequisite to your other project 2. you could launch it through a "Launch File" custom action. However, please note that here you can not schedule the custom action everyw...
by Catalin
Fri Sep 17, 2021 4:09 pm
Forum: Common Problems
Topic: Error calling MSI API: 1627 Method: MsiDatabaseImport Table: Component. Extended Error: Write Table IDT: 1: 2216
Replies: 5
Views: 63

Re: Error calling MSI API: 1627 Method: MsiDatabaseImport Table: Component. Extended Error: Write Table IDT: 1: 2216

Hello Anthony, It looks like the issue was not a duplicate event, but rather you have somehow ended up with an empty component (the "_" component from the "Organization" page). To be fully honest with you, I am not quite sure how you ended up with that, as I have tried to reproduce this several time...
by Catalin
Fri Sep 17, 2021 1:55 pm
Forum: Common Problems
Topic: Error calling MSI API: 1627 Method: MsiDatabaseImport Table: Component. Extended Error: Write Table IDT: 1: 2216
Replies: 5
Views: 63

Re: Error calling MSI API: 1627 Method: MsiDatabaseImport Table: Component. Extended Error: Write Table IDT: 1: 2216

Hello,

There seem to be some duplicates in the "Component" table of your project.

Please forward us a copy of your .AIP file by e-mail at support at advancedinstaller dot com so we can further investigate this.

Best regards,
Catalin
by Catalin
Fri Sep 17, 2021 12:44 pm
Forum: Common Problems
Topic: Merge Module Custom Action With NOT Property Condition
Replies: 10
Views: 2363

Re: Merge Module Custom Action With NOT Property Condition

Thank you for your followup on this, Scott!

I am glad to hear everything is working as expected now.

Best regards,
Catalin
by Catalin
Thu Sep 16, 2021 2:42 pm
Forum: Building Installers
Topic: Delete .exe install
Replies: 4
Views: 101

Re: Delete .exe install

Hello and welcome to our forums, And if there is no exe package, then the script would not work. But at the moment, the script always fires and always displays a completion dialog, regardless of what choice was made in the script. Here, we will need to condition the execution of the script. To do so...
by Catalin
Wed Sep 15, 2021 6:02 pm
Forum: Common Problems
Topic: What do the exit codes mean?
Replies: 1
Views: 789

Re: What do the exit codes mean?

Hello, You can find a list of all the possible returned codes of our Updater tool here: Updater return codes In your case, it might be an actualy system error (because our Updater does not return "3" in any scenario). For more information about this, please refer to the following Microsoft article: ...
by Catalin
Wed Sep 15, 2021 5:51 pm
Forum: Building Installers
Topic: error code 1603 - Again looks like....
Replies: 2
Views: 818

Re: error code 1603 - Again looks like....

Hello Marcin, Unfortunately, I can not really say why this is happening (the log file does not really ofer many details, beside the custom action that fails). This looks to be a proprietary custom action of ours that deals with JSON files. Are you able to replicate this behavior on multiple machines...
by Catalin
Wed Sep 15, 2021 5:44 pm
Forum: Building Installers
Topic: Build exe without manifest question?
Replies: 3
Views: 1896

Re: Build exe without manifest question?

Hello, Unfortunately, I am no expert in this subject either. I have tried to havea look right now and I have found the following: - open your VS solution - right click on your project --> "Properties" --> "Applicaiton" tab - under "Icon and manifest" --> "Manifest" --> click on the dropdown button a...
by Catalin
Tue Sep 14, 2021 5:52 pm
Forum: Feature Requests
Topic: Custom Setup Tips Dialog
Replies: 1
Views: 990

Re: Custom Setup Tips Dialog

Hello, Thank you very much for sharing this with us! I am sure some other InstallShield users who have migrated to Advanced Installer will find this useful. If possible, could you please try to edit the post and re-attach the last image, as it looks like a wrong one was attached? Best regards, Catalin
by Catalin
Tue Sep 14, 2021 4:10 pm
Forum: Common Problems
Topic: Problems with setting .net framework 4.8 as mandatory prerequisite.
Replies: 8
Views: 4930

Re: Problems with setting .net framework 4.8 as mandatory prerequisite.

Hello Andre, As promised, here is my followup after further investigating this. It looks like I was indeed right about the reason why this is happening. Basically, the scheduled task that is created to restart the setup after the reboot is not removed in due time (it is removed after the user presse...
by Catalin
Tue Sep 14, 2021 1:24 pm
Forum: Common Problems
Topic: Problems with setting .net framework 4.8 as mandatory prerequisite.
Replies: 8
Views: 4930

Re: Problems with setting .net framework 4.8 as mandatory prerequisite.

Hello Andre, First of all, please accept my apologies for the delayed reply. I have indeed mananged to reproduce this on my end as well using the current scenario. Unfortunately, I can not say for sure why this is happening. I will need some more time to further investigate this and I will followup ...
by Catalin
Tue Sep 14, 2021 11:15 am
Forum: Common Problems
Topic: Installer autodetects compile time references instead of runtime references - uses ref folder instead of lib folder
Replies: 5
Views: 2574

Re: Installer autodetects compile time references instead of runtime references - uses ref folder instead of lib folder

Hello,

Thank you for your followup on this!

We are glad to hear everything works as expected now.

Yes, this should be included in the next version of Advanced Installer.

Best regards,
Catalin
by Catalin
Tue Sep 14, 2021 11:13 am
Forum: Building Installers
Topic: Windows Feature Bundles Not Installing
Replies: 26
Views: 14835

Re: Windows Feature Bundles Not Installing

Hello Immanuel and welcome to our forums,

The next release of Advanced Installer is scheduled (at least internally) next Tuesday (Sep 21st).

I have sent the download link for the .DLL, just in case we might have some delays with the release.

Hope that will help!

Best regards,
Catalin

Go to advanced search