Search found 93 matches

Go to advanced search

by ChrisGue
Wed Jul 13, 2016 10:48 am
Forum: Common Problems
Topic: How to terminate all instances of e.g. explorer.exe
Replies: 9
Views: 3683

How to terminate all instances of e.g. explorer.exe

Hello,

to install a windows explorer comntext menu handler (dll) the explorer needs to be terminated.
But there can be more intances of explorer.exe, I have seen systems with 7 instances.
How to terminate all of them?

Chris
by ChrisGue
Wed Jul 13, 2016 10:41 am
Forum: Common Problems
Topic: Problems installing a windows explorer extension
Replies: 5
Views: 2442

Re: Problems installing a windows explorer extension

This happens because you are archiving your installation files using our LZMA compresion support. The related upgrade order cannot be used alongside the LZM compression. To avoid this restriction you can go to "Media page -> and choose another archiving option. CAB files is selected and not LZMA, s...
by ChrisGue
Mon Jun 27, 2016 8:41 pm
Forum: Common Problems
Topic: Problems installing a windows explorer extension
Replies: 5
Views: 2442

Re: Problems installing a windows explorer extension

Thanks for your reply. 1. This does not work, when the installation is started with "run as", e.g. when the user cannot elevate privileges and another account is required to install software. In this case an option might be to log off the current user or prompt to restart the system. For this I need...
by ChrisGue
Thu Jun 23, 2016 11:54 am
Forum: Common Problems
Topic: Problems installing a windows explorer extension
Replies: 5
Views: 2442

Problems installing a windows explorer extension

Hello, I use the AI enterprise (7.1.3). With my software a dll for the windows explorers context menu is installed. For this the the windows epxlorer process needs to be terminated. This causes is many cases problems: 1. It seems the installation is only able to shut down ONE explorer.exe. But there...
by ChrisGue
Tue May 17, 2016 11:01 am
Forum: Common Problems
Topic: (Re)start Explorer after installation
Replies: 5
Views: 2041

Re: (Re)start Explorer after installation

I still have the problem, that restarting the explorer at the end of the installation start it as administartor (on some machines). So my idea is to start an application at the start of the installation (running in the background) and waiting for a registry key. So I need to set a registry key at th...
by ChrisGue
Thu Apr 28, 2016 11:38 am
Forum: Common Problems
Topic: (Re)start Explorer after installation
Replies: 5
Views: 2041

Re: (Re)start Explorer after installation

It is here:
Advanced Installer001.png
Advanced Installer001.png (7.36 KiB) Viewed 2026 times
So, this should be fine?
by ChrisGue
Wed Apr 27, 2016 11:51 am
Forum: Common Problems
Topic: (Re)start Explorer after installation
Replies: 5
Views: 2041

(Re)start Explorer after installation

Hello, I use the AI 7.1.3 corporate. for the installation the explorer needs to be shut down. Though I am restarting it at the end of the installation. But in case the user has no privileges to install software, the installation is executed with the administrator account, though the explorer is star...
by ChrisGue
Mon Aug 25, 2014 9:51 am
Forum: Common Problems
Topic: pass a file via the command line
Replies: 5
Views: 2185

Re: pass a file via the command line

Thanks, with deferred with no impersonation this is working now.
by ChrisGue
Wed Aug 20, 2014 12:27 pm
Forum: Common Problems
Topic: pass a file via the command line
Replies: 5
Views: 2185

Re: pass a file via the command line

Thanks for the answer, Yes, that's working. But when I use the parameter /passive the file not being copied. e.g. Myinstallation.exe ADDFILE="x:\datas\settings.zip" works fine Myinstallation.exe /passive ADDFILE="x:\datas\settings.zip" is not working I have added the custom action in Commit,with 'Sy...
by ChrisGue
Fri Aug 15, 2014 4:02 pm
Forum: Common Problems
Topic: pass a file via the command line
Replies: 5
Views: 2185

pass a file via the command line

Hello, I use the AI enterprise 7.1.3 I would like (optionally) to pass a file via the command line to the installer exe. In case a file is passed via the command line, it shall be copied to the program folder. e.g: MyInstallation.exe /ADDTHIS="c:\test\settings.ini" Is this possible? If so, how? Chris
by ChrisGue
Thu Jan 09, 2014 5:14 pm
Forum: Common Problems
Topic: problems with grafic positioning
Replies: 4
Views: 1904

Re: problems with grafic positioning

Thanks,
I could edid the aip file.
Although wondering why the dialog editor has here a wrong limitation.

Best regards,
Christoph
by ChrisGue
Tue Jan 07, 2014 7:43 pm
Forum: Common Problems
Topic: problems with grafic positioning
Replies: 4
Views: 1904

problems with grafic positioning

Hello, I use the AI 7.1.3 corporate In the dialog editor I have put the header grafic to coordinates x=0 and y=0 But when I run the installation the grafic is not at the top, there is a gap of 1 pixel, see clpEF5D.png And the lines do not reach to the right border, there is little gap, see clpA2C1.p...
by ChrisGue
Tue Aug 20, 2013 10:29 am
Forum: Common Problems
Topic: restart explorer after installation
Replies: 1
Views: 1918

restart explorer after installation

I use the AI 7.1.3 corporate.
My installation installs an explorer context menu extension (a dll)
When an old version is updated, the explorer is closed, but not restarted afterwards, although it should be.

How to solve this?

Regards, Chris
by ChrisGue
Fri Jun 28, 2013 11:23 am
Forum: Common Problems
Topic: Product Code is changed during installation
Replies: 3
Views: 3298

Re: Product Code is changed during installation

Thanks for the answer. Now my customer complains about that again. He installs our software via the product code. But uninstalling with that product code does not work, as the product code was changed. And his installation environment uses the product code. Any solution for that? I do not see the "P...
by ChrisGue
Wed Dec 19, 2012 11:20 am
Forum: Common Problems
Topic: Product Code is changed during installation
Replies: 3
Views: 3298

Product Code is changed during installation

Hello, I use the AI 7.1.3 corporate. Now a customer told that the Product Code is changed during installation. From the log: MSI (s) (AC:C4) [15:18:41:357]: Product Code from property table before transforms: '{4BEEBA03-2560-42DB-9B17-805FB7278E7A}' MSI (s) (AC:C4) [15:18:41:357]: Product Code from ...

Go to advanced search