Search found 112 matches

Go to advanced search

by prerak6962
Mon Aug 19, 2019 3:20 pm
Forum: Common Problems
Topic: Service User Account Password Masked
Replies: 17
Views: 26674

Re: Service User Account Password Masked

Hi Catalin,

Did you get a chance to have a look at the above mentioned issue?

Thanks.
Prerak
by prerak6962
Tue Aug 13, 2019 1:27 pm
Forum: Common Problems
Topic: Shared prerequisite between multiple features
Replies: 7
Views: 10979

Re: Shared prerequisite between multiple features

Okay. I'll give it a shot.

Thanks.
Prerak
by prerak6962
Mon Aug 12, 2019 5:01 pm
Forum: Common Problems
Topic: Service User Account Password Masked
Replies: 17
Views: 26674

Re: Service User Account Password Masked

Hi Catalin, I am encountering another issue now... :cry: My service depends on the registry. It reads a few parameters from the registry on start. But as I moved the "WriteRegistryValues" action after "StartServices" action, the service is not able to read the required registry values. So, now if I ...
by prerak6962
Mon Aug 12, 2019 4:53 pm
Forum: Common Problems
Topic: Shared prerequisite between multiple features
Replies: 7
Views: 10979

Re: Shared prerequisite between multiple features

Hi Eusebiu, I'm afraid that you can achieve what you want only through a feature selection dialog I have the feature selection dialog in the installer. It is the default "ConfigureDlg". However, the prerequisite feature is hidden as it's a compulsory prerequisite so I don't want the user to deselect...
by prerak6962
Mon Aug 12, 2019 8:57 am
Forum: Common Problems
Topic: Shared prerequisite between multiple features
Replies: 7
Views: 10979

Re: Shared prerequisite between multiple features

Hi Eusebiu, Thank you the reference link. Is it completely necessary to build a custom feature selection dialog? The prerequisite feature is marked as "Not Installed" in "Organisation" page. I tried setting the following condition in the "Installed If" field: ((&FA = 3) AND NOT (!FA = 3)) OR ((&FB =...
by prerak6962
Thu Aug 08, 2019 3:53 pm
Forum: Common Problems
Topic: Service User Account Password Masked
Replies: 17
Views: 26674

Re: Service User Account Password Masked

Hi Catalin, Thank you for the answers. It certainly helped. After setting "AI_SecureProperty" sequence value to 5860 I was able to successfully install the application. How ever, the update was still failing as the installer was not able to decrypt the encrypted value. Upon further investigation, I ...
by prerak6962
Mon Aug 05, 2019 11:12 am
Forum: Common Problems
Topic: Service User Account Password Masked
Replies: 17
Views: 26674

Re: Service User Account Password Masked

Hi Catalin, After further investigation I was able to move a bit forward. Unable to find a solution though. All this is happening during "First Install". If I check the value of a secure property after the "Searhes" stage in "Install Execution Stage" it is same as what user entered (unencrypted). Ho...
by prerak6962
Thu Aug 01, 2019 4:41 pm
Forum: Common Problems
Topic: Service User Account Password Masked
Replies: 17
Views: 26674

Re: Service User Account Password Masked

Hi Catalin, My bad. I did not realize there was a second page. After reading it, it seems it should work. So I integrated the custom actions provided in the last sample project on that thread. The only thing that I added was "Upgrade" execution stage for those custom actions. However, after these ch...
by prerak6962
Wed Jul 31, 2019 3:35 pm
Forum: Common Problems
Topic: Service User Account Password Masked
Replies: 17
Views: 26674

Re: Service User Account Password Masked

Hi Catalin, Thank you for the link. I am trying to achieve the exact same thing as Collins in the other post. If I understood it correctly, I'll need to write an external application (in C++ or Java or .NET) which would decrypt the password and store it in a public property of the installer. Unfortu...
by prerak6962
Wed Jul 31, 2019 2:13 pm
Forum: Common Problems
Topic: Service User Account Password Masked
Replies: 17
Views: 26674

Re: Service User Account Password Masked

Hi Catalin, Now there's one more issue that I am facing in my project. During an update, I only have to update the files and nothing else. As per my understanding, during an update process, the installer deletes the service -> uninstalls the old version -> installs the new version -> installs the se...
by prerak6962
Fri Jul 19, 2019 9:50 am
Forum: Common Problems
Topic: Shared prerequisite between multiple features
Replies: 7
Views: 10979

Shared prerequisite between multiple features

Hello, In one of my project I have a prerequisite that needs to be installed. The project has multiple features (A, B, C for the moment). I want that prerequisite should be installed if the user selects Feature A or Feature B or both. To achieve this, I added a feature based prerequisite and I could...
by prerak6962
Fri Jul 19, 2019 9:35 am
Forum: Common Problems
Topic: Service User Account Password Masked
Replies: 17
Views: 26674

Re: Service User Account Password Masked

Hi Catalin, Thank you for the response. Your solution works perfectly fine. However, it would be better to see the properties name instead of masked characters in order to avoid any typing mistakes. It can be very difficult to find this mistake if there is one. Maybe a property picker dialog can be ...
by prerak6962
Fri Jul 12, 2019 2:21 pm
Forum: Common Problems
Topic: Property value not set
Replies: 5
Views: 1937

Re: Property value not set

Hi Kratzer, Catalin,

Indeed it was the language issue.
I had forgot to add the translation for the newly added property.

Thank you for the help.

Prerak
by prerak6962
Fri Jul 12, 2019 2:20 pm
Forum: Common Problems
Topic: Feature List not displayed correctly
Replies: 4
Views: 1609

Re: Feature List not displayed correctly

Hi Catalin,

Thank you the update.
I updated Advanced installer and it's all good now.
by prerak6962
Fri Jul 12, 2019 2:08 pm
Forum: Common Problems
Topic: Service User Account Password Masked
Replies: 17
Views: 26674

Service User Account Password Masked

Hello, In my project, I have to create a service and assign an user account to it. The user account is created before hand on the domain. So, in order to achieve this, I add a new dialog in the installer which asks for the domain name, username and the password of the service user. Now, in the "Serv...

Go to advanced search