Search found 4327 matches

Go to advanced search

by Catalin
Wed Jul 18, 2018 1:50 pm
Forum: Building Installers
Topic: Updater
Replies: 2
Views: 1058

Re: Updater

Hello, First of all, can you please make sure you do not have the "Check and automatically install" option ticked in the "Updater" page, under "Update Behavior" tab ? This option checked has the same result as the "/silentall" command line, which will make the updater to search silently for updates ...
by Catalin
Wed Jul 18, 2018 1:47 pm
Forum: Building Installers
Topic: Upgrade Code
Replies: 3
Views: 1840

Re: Upgrade Code

Hello Ian and welcome to our forums, "I need to build an install which will first uninstall the existing version" In order to achieve that, the products must have the same Upgrade Code and the product version of the software you are installing must be higher than the product version of the already i...
by Catalin
Wed Jul 18, 2018 11:57 am
Forum: Common Problems
Topic: Auto Close Applications not restarting app
Replies: 7
Views: 2498

Re: Auto Close Applications not restarting app

Hello, First of all, the project you have sent me is different from the picture you have attached in your first post. Please keep in mind that it is recommended to use the "Windows Title Prefix" . Also, please keep in mind that the restart could fail if the application does not support a command lin...
by Catalin
Wed Jul 18, 2018 8:59 am
Forum: Common Problems
Topic: How to Uninstall expressions.. ?
Replies: 1
Views: 565

Re: How to Uninstall expressions.. ?

Hello and welcome to our forums, In order to achieve what you want, you can create a new Dialog which will contain few checkboxes (one for each of your features) and then condition the install of each feature based on the state of your checkbox. After that, you can further use the state of the check...
by Catalin
Wed Jul 18, 2018 7:49 am
Forum: Common Problems
Topic: Controls toolbox not showing
Replies: 9
Views: 3419

Re: Controls toolbox not showing

Hello,

I am not sure why you encounter this behavior. I have tested it and it works fine.

Here are some screenshots:
-for 14.5.2
14.5.2.PNG
14.5.2.PNG (211.86 KiB) Viewed 3410 times
-for 15.0.1
15.01.PNG
15.01.PNG (227.67 KiB) Viewed 3410 times
I have tested this on Windows 10.

Can you please give me more details about your OS ?

Regards,
Catalin
by Catalin
Tue Jul 17, 2018 8:57 am
Forum: Building Installers
Topic: Howdo you think about Decompressing files ?
Replies: 1
Views: 844

Re: Howdo you think about Decompressing files ?

Hello, Yes, this is achievable by using our "LZMA compression" predefined support. In order to do this, you can go to "Builds" page from "Package Definition" group and check the "Archive installation files using LZMA compression" . This way, a 7zip archive will be created on the user's computer. For...
by Catalin
Tue Jul 17, 2018 7:55 am
Forum: Building Installers
Topic: Install Service with custom login
Replies: 7
Views: 2888

Re: Install Service with custom login

Hello Srikanth,

In order for the the UI to be showed upon uninstalling, you can check the "Disable Remove" option from "Product Details" page --> "Add or Remove Programs (Control Panel)".

Hope this helps!

Regards,
Catalin
by Catalin
Mon Jul 16, 2018 1:33 pm
Forum: Common Problems
Topic: ProductFullVersion property
Replies: 1
Views: 900

Re: ProductFullVersion property

Hello, I have tried to reproduce your scenario, but I could not replicate the behavior. Here are the steps I took to reproduce it: 1) Created a project and added a .EXE file to it. 2) Created the "ProductFullVersion" Property in "Install Parameters" page with, let's say, the value 1.0.0.1 . 3) Went ...
by Catalin
Mon Jul 16, 2018 9:11 am
Forum: Common Problems
Topic: Issue trying to package AutoBid Apps
Replies: 3
Views: 1317

Re: Issue trying to package AutoBid Apps

Hello, In order to test this behavior, we need the .aip (project file) and the necessary resources. If you can not share with us the resources needed to reproduce this behavior, you can try to divest the project to the point where the issue still persists. Also, I noticed that you are using an older...
by Catalin
Mon Jul 16, 2018 8:41 am
Forum: Building Installers
Topic: Install Service with custom login
Replies: 7
Views: 2888

Re: Install Service with custom login

Hello Srikanth, I am not sure why you encounter this behavior. Can you please try to disable "Override Windows Installer programs list entry" option from "Product Details" page --> "Product Details" tab and retest it ? If this does not help, can you please try to create a "verbose log" of the uninst...
by Catalin
Mon Jul 16, 2018 7:50 am
Forum: Building Installers
Topic: Passing in Version Number when Building from Command Line
Replies: 3
Views: 1569

Re: Passing in Version Number when Building from Command Line

You're always welcome!

I'm glad you got this working!

Regards,
Catalin
by Catalin
Fri Jul 13, 2018 2:43 pm
Forum: Common Problems
Topic: Issue trying to package AutoBid Apps
Replies: 3
Views: 1317

Re: Issue trying to package AutoBid Apps

Hello,

I am not sure why you encounter this behavior.

Can you please send us the .aip (project file) and the necessary resources to reproduce this behavior by e-mail at support at advancedinstaller dot com so we can investigate its settings and test it on our side ?

Regards,
Catalin
by Catalin
Fri Jul 13, 2018 2:12 pm
Forum: Common Problems
Topic: Cannot remove the product due to error code 1603
Replies: 1
Views: 853

Re: Cannot remove the product due to error code 1603

Hello Zsolt, Some of our custom actions have support for extended debug logging. This can be activate by setting the AI_DEBUGLOG property to "1" during install / uninstall time. This functionality is available for both EXE and MSI packages. Can you please try to see if the AI_FwRemove will log any u...
by Catalin
Fri Jul 13, 2018 11:20 am
Forum: Building Installers
Topic: Install Service with custom login
Replies: 7
Views: 2888

Re: Install Service with custom login

Hello Srikanth, I am afraid you can not pass a value from your pre-install prerequisite to the main package through a property. As a workaround, you can create a registry entry in your prerequisite package which will contain the user you have just created and, after the prerequisite is installed, yo...
by Catalin
Fri Jul 13, 2018 10:05 am
Forum: Building Installers
Topic: Passing in Version Number when Building from Command Line
Replies: 3
Views: 1569

Re: Passing in Version Number when Building from Command Line

Hello, In order to execute more commands at a time, you can create a file which executes multiple commands. After that, you can use the following command in your command line : AdvancedInstaller.com /execute <path_to_project_file> <command_file_path> For more information about this, you can check ou...

Go to advanced search