Nice to have a warning for Missing Services to Install

Request new features that you would like to see in the next version of Advanced Installer.
Post Reply
jmenter
Posts: 1
Joined: Thu Apr 28, 2016 2:12 pm

Nice to have a warning for Missing Services to Install

Post by jmenter » Mon Jan 20, 2020 7:55 pm

Hi,

I'd like to request an enhancement for a problem that has caught me several times and caused installs to fail.

If I load a project with a Service that is installed and the service EXE is currently missing (not built yet), it deletes the entry from the 'Services'/Services to Install' menu and if I save the project, the next time I build, it fails to install because of the 'Services to Install' is missing, but the Control operations and Failure operations are still there and cause the installer to error out.

It'd be nice if it checked on startup and displayed a warning if the service exe isn't present instead of just silently deleting it!

Thanks,

Joe

Catalin
Posts: 3118
Joined: Wed Jun 13, 2018 7:49 am

Re: Nice to have a warning for Missing Services to Install

Post by Catalin » Tue Jan 21, 2020 10:43 am

Hello Joe and welcome to Advanced Installer forums,

Unfortunately, I am not quite sure I understand your scenario here.

Could you please give me a step by step test-case which I can follow in order to reproduce this?

Looking forward to hearing from you.

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Post Reply