1619 error when installing with SCCM

Having trouble running Advanced Installer? Got a bug to report? Post it all here.
Cygnusx1
Posts: 1
Joined: Fri Dec 07, 2018 12:36 am

1619 error when installing with SCCM

Postby Cygnusx1 » Fri Dec 07, 2018 12:48 am

Receiving 1619 error when installing in SystemContext with SCCM. This is a vendor software so setup.exe cannot be edited. SCCM is setup to install with Administrative rights. I can simply duplicate the issue with psexec. Is this an extraction folder issue? Is there a way to change the extraction folder at runtime?
The failure occurs at the AI_FindExeLzma CA. The error appears if installing the setup.exe or the .msi. Tried setting AI_EXE_EXTRACTION_FOLDER and AI_PREREQS_DIR to c:\ProgramData.
unfortunately this is an emergency package and help is needed yesterday.
Thank you in advance for a solution.

Eusebiu
Posts: 4434
Joined: Wed Nov 14, 2012 2:04 pm

Re: 1619 error when installing with SCCM

Postby Eusebiu » Tue Dec 11, 2018 4:19 pm

Hi and welcome to our forums.

By default an Advanced Installer package of an EXE type is extracted under the %appdata% folder. This folder can be changed in the "Extraction location" field from the "Builds" page. I'm afraid that it cannot be changed at install time.

When a package is installed under the SYSTEM account its %appdata% folder path is located under the system profile's folder ("C:\Windows\System32\config\systemprofile"). However, due to a security measure, Advanced Installer prevents the extraction to "Windows" folder and the extraction path is changed to the Windows root folder (e.g. C:\).

The setup extraction may fail if the SYSTEM account does not have permissions to the root folder on that machine.

Best regards,
Eusebiu
Eusebiu Aria - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube


Return to “Common Problems”

Who is online

Users browsing this forum: No registered users and 2 guests