[solved] Updater doesn't work while looking for https-URL

Having trouble running Advanced Installer? Got a bug to report? Post it all here.
Post Reply
Peter
Posts: 17
Joined: Thu Dec 10, 2015 11:52 am

[solved] Updater doesn't work while looking for https-URL

Post by Peter » Wed Apr 10, 2019 1:57 pm

Hi Forum,

I'm using Advanced Installer 8.5.

Our Updater works fine for many years. A few months ago we have activatet the SSL-certificate for our webserver where is the Updates-URL based.

Now I get errors when trying to check for updates. The german Message means: "The HTTP redirect request could not be performed." (the message is translated by me, I'm not sure if this is the exact message in english, but the meaning is correct)
10-04-_2019_14-46-59.png
Error message while checking for Updates
10-04-_2019_14-46-59.png (3.98 KiB) Viewed 138 times

The URL to check is (it is reachable when copy this URL in to a browser)

Code: Select all

https://www.cseTools.de/Setups/cseTools2018/update-info/cseTools2018Update64.txt
If you want, i can upload my updater with the uses ini-file.

What can I do to perform the updates?

Thank you for your help.
Peter
Last edited by Peter on Tue Apr 16, 2019 12:44 pm, edited 1 time in total.

Daniel
Posts: 7605
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: Updater doesn't work while looking for https-URL

Post by Daniel » Thu Apr 11, 2019 12:34 pm

Hello Peter,

I'm not so sure why this happens.

Yes, if you could send us by email to support at advancedinstaller dot com a download link for your updater.ini file (the one which resides beside the installed Updater.exe file) so we can check and test its settings this will be great.

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Peter
Posts: 17
Joined: Thu Dec 10, 2015 11:52 am

Re: Updater doesn't work while looking for https-URL

Post by Peter » Mon Apr 15, 2019 8:16 am

thank you Daniel. I've send an email with the updater.ini, the setup.aip and the updater.aip (to create the updater.txt)

Daniel
Posts: 7605
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: Updater doesn't work while looking for https-URL

Post by Daniel » Tue Apr 16, 2019 9:23 am

Hello Peter,

We tested your scenario and replicated the behavior: the http redirect request failed error was thrown when the Updater tried to download the "cseTools2019Update64.txt" file from your web server.

After talking with our dev team about this issue, they suggested this could happen due to our Updater user agent used when posting HTTP requests. Our Updater tool uses the following user agent:

Code: Select all

AdvancedInstaller
Can you please check your web server settings and make sure that HTTP request received from our "AdvancedInstaller" user agent are allowed?

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Peter
Posts: 17
Joined: Thu Dec 10, 2015 11:52 am

Re: Updater doesn't work while looking for https-URL

Post by Peter » Tue Apr 16, 2019 11:21 am

Hello Daniel,

I've checked the server log file and found a lot of entries like

Code: Select all

csetools.de anon-212-23-154-6.ip.invalid - - [16/Apr/2019:10:43:02 +0200] "GET /Setups/cseTools2018/update-info/cseTools2018Update64.txt HTTP/1.1" 301 288 "-" "AdvancedInstaller"
I will try to find out, if the web server blocks the user agent.
Before we have installed our SSL-certificate, the updater works perfect.

Peter
Posts: 17
Joined: Thu Dec 10, 2015 11:52 am

Re: Updater doesn't work while looking for https-URL

Post by Peter » Tue Apr 16, 2019 12:43 pm

Thank you Daniel for all the support.
The user agent "AdvancedInstaller" is allowed at the server.

Now I found the cause of this error and can fix it.

The reason is placed in my .htaccess file at the web server.
I've changed the Rewrite conditions and rules from

Code: Select all

RewriteCond %{HTTP_HOST} !^www.DOMAIN.de$
RewriteRule ^(.*) https://www.DOMAIN.de/$1 [L,R=301]
to

Code: Select all

RewriteCond %{HTTPS} !=on
RewriteRule ^/?(.*) https://www.DOMAIN.de/$1 [L,R=301]
The problem is solved!
Hope the solution helps all others too.

Daniel
Posts: 7605
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: [solved] Updater doesn't work while looking for https-URL

Post by Daniel » Wed Apr 17, 2019 7:54 am

Thank you for sharing with us this information. I'm sure it will be useful for other customers too.

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Post Reply