dorramati
Posts: 1
Joined: Sun Nov 28, 2021 9:38 am

AI_RestartElevated

Sun Nov 28, 2021 9:43 am

Hi,
Setup fails on some computers.
We are running it with Admin rights.

Error in verbose log:
Action 08:03:33: AI_RestartElevated.

Action start 08:03:33: AI_RestartElevated.
MSI (c) (78:84) [08:03:33:321]: Invoking remote custom action. DLL: C:\Users\Install.NMA\AppData\Local\Temp\MSI7685.tmp, Entrypoint: RestartElevated
MSI (c) (78!64) [08:03:33:353]: PROPERTY CHANGE: Adding AiSkipUserExit property. Its value is '1'.
CustomAction AI_RestartElevated returned actual error code 1602 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 08:03:33: AI_RestartElevated. Return value 2.
MSI (c) (78:24) [08:03:33:696]: Skipping action: UserExit (condition is false)
Action ended 08:03:33: INSTALL. Return value 2.
MSI (c) (78:24) [08:03:33:696]: Destroying RemoteAPI object.
MSI (c) (78:9C) [08:03:33:712]: Custom Action Manager thread ending.

Liviu
Posts: 258
Joined: Tue Jul 13, 2021 11:29 am
Contact:  Website

Re: AI_RestartElevated

Mon Nov 29, 2021 9:03 am

Hello and welcome to our forums,

I investigated it and tried to reproduce the behavior, but I was not able to replicate it. There may be some environment settings that influence this, but we couldn't find them yet.

Does the problem reproduce when you just double-click your package? Do you send any command line to it or take any action that could influence this? Can you reproduce the problem in a new project? Also can you tell me the operating system and Advanced Installer version?

In order for us to further investigate this issue, can you please send us the following resources:
  1. the .AIP (setup project) file
  2. an installation log
  3. and a download link for your setup package
by email to support at advancedinstaller dot com.

Or, even better, could you please create a sample project that reproduces this and forward it to me?

Best regards,
Liviu
________________________________________
Liviu Sandu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Common Problems”