vinaysalian
Posts: 6
Joined: Thu Sep 29, 2022 11:38 am

Dot NEt 3.5 Prerequisite

Fri Sep 30, 2022 6:21 am

[Hello everyone,

Thank you for creating this wonderful application. I am still trying out most of the Enterprise Installer features. However , there is one issue is though i add a prerequisite Dot net 3.5 and tell the installer to use files from the disk , still it asks me download the feature from the internet and then asks for a reboot . Is there a way where I can avoid this since most of the Machines i will be installing will be standalone machines which wont have access to the internet .

Liviu
Posts: 588
Joined: Tue Jul 13, 2021 11:29 am
Contact:  Website

Re: Dot NEt 3.5 Prerequisite

Fri Sep 30, 2022 8:10 am

Hello and welcome to our forums,

I'm afraid this is related to the .NET setup itself. If you manually launch the setup outside of Advanced Installer you will see that it prompts to download and install:
dot net prereq.png
dot net prereq.png (179.26KiB)Viewed 3941 times

Unfortunately, I cannot find an offline installer for this prerequisite on Microsoft website. This page downloads the same installer package (which requires internet).

As a possible solution, you can try to enable the .NET Framework 3.5 using our Windows Feature bundle support:
windows feature.png
windows feature.png (126.34KiB)Viewed 3941 times

Hope this helps! If you have any other questions, please don’t hesitate to contact us.

Best regards,
Liviu
________________________________________
Liviu Sandu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

vinaysalian
Posts: 6
Joined: Thu Sep 29, 2022 11:38 am

Re: Dot NEt 3.5 Prerequisite

Fri Sep 30, 2022 12:06 pm

Thank you for the quick update and support, We could enable it windows Feature bundle , but the prerquisite SQL 2014 express Advanced installation needs dot net 3.5 installed before the SQl installation starts . and Windows feature runs later so that wont solve the purpose .

Liviu
Posts: 588
Joined: Tue Jul 13, 2021 11:29 am
Contact:  Website

Re: Dot NEt 3.5 Prerequisite

Fri Sep 30, 2022 12:56 pm

Hello,

In this case you can create a completely separate setup package only for turning on/off the Windows features. Then you can add this package as a pre-install prerequisite (it should be added before the other prerequisites in the "Prerequisites" page list) to your main project.

You can read more about that on our How to configure help setup package within the installer article.

Also, you have the possibility to define install conditions so that the prerequisite for activating .NET 3.5 will start only on machines with this feature disabled.
Note: The prerequisites from the "Prerequisites" page are executed in the order they are added/scheduled in the list. Based on that, you need to move to the top of the list, the prerequisite which enables .NET.

Hope this helps! If you have any other questions, please don’t hesitate to contact us.

Best regards,
Liviu
________________________________________
Liviu Sandu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

vinaysalian
Posts: 6
Joined: Thu Sep 29, 2022 11:38 am

Re: Dot NEt 3.5 Prerequisite

Fri Sep 30, 2022 1:32 pm

Thank You Liviu for the support . ill try that..and let you know. Thanks again for the help

Liviu
Posts: 588
Joined: Tue Jul 13, 2021 11:29 am
Contact:  Website

Re: Dot NEt 3.5 Prerequisite

Fri Sep 30, 2022 1:54 pm

You're always welcome!

Best regards,
Liviu
________________________________________
Liviu Sandu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Common Problems”