karthickeyan kannan
Posts: 1
Joined: Fri Feb 23, 2024 8:28 am

Issue with Repair Process - CAB and MSI Files Being Deleted After Installation

During the repair process of my application, I encountered an error message stating, "An installation package cannot be found. Try the installation again using a valid copy of the installation package .msi". This issue arises when attempting to repair the installed application, suggesting that the installer cannot locate the necessary MSI file for the repair process.

I have researched this problem in the Advanced Installer forums and followed the recommended solution to address it. Specifically, I configured the bootstrapper parameters to "Do not delete extracted CAB and MSI files" with the aim of ensuring these critical files remain available for the repair process. Despite this configuration, it appears that the CAB and MSI files are still being deleted after the installation completes, leading to the failure of the repair operation.

How to properly configure my Advanced Installer project to prevent the deletion of CAB and MSI files post-installation. My objective is to ensure a seamless repair process for the application without encountering the aforementioned error.
AF-BootstrapperSettings2.JPG
AF-BootstrapperSettings2.JPG (15.43 KiB) Viewed 2313 times
AF-BootstrapperSettings1.JPG
AF-BootstrapperSettings1.JPG (87.12 KiB) Viewed 2307 times
Liviu
Posts: 1047
Joined: Tue Jul 13, 2021 11:29 am
Contact: Website

Re: Issue with Repair Process - CAB and MSI Files Being Deleted After Installation

Hello and welcome to our forums,

As I see, my colleague Eusebiu has replied to you over the email.

Please continue the conversation there to avoid duplicate threads.

Best regards,
Liviu
________________________________________
Liviu Sandu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Common Problems”