MSI uninstall doesn't remove files

Having trouble running Advanced Installer? Got a bug to report? Post it all here.
Post Reply
Centranthus
Posts: 4
Joined: Fri Aug 03, 2012 8:05 am

MSI uninstall doesn't remove files

Post by Centranthus » Sun Aug 05, 2012 3:40 pm

Hi,

I have inherited an installer project which installs a simple desktop application. Installation seems to work fine but if I then uninstall the exe using either Control Panel or the Uninstall link in the Start menu folder the application folder and the exe are left behind (even though the start menu shortcuts and the registry entries are removed). There are no errors.

If I use the installer package to uninstall the program the file and folder are removed correctly, so it seems to be a problem with MSI uninstallation.

I have tested this on Win7 and Win7-64. Using Advanced Installer 9.4 (but the same thing happened with 9.3). I will supply the aip and built installer via email.

Any idea what the problem might be?

Thanks,

Phil

Daniel
Posts: 8142
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: MSI uninstall doesn't remove files

Post by Daniel » Wed Aug 08, 2012 7:09 am

Hello Phil and welcome to Advanced Installer forums,

I'm not sure why you are encountering this behavior. Can you reproduce the behavior on multiple clean machines? If so, can you please send us the .AIP (project file) and a verbose log of the installation to support at advancedinstaller dot com so we can investigate them?

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Centranthus
Posts: 4
Joined: Fri Aug 03, 2012 8:05 am

Re: MSI uninstall doesn't remove files

Post by Centranthus » Sat Aug 11, 2012 8:51 am

Hi Daniel,

I have generated install and uninstall logs and sent them to you. (I sent the aip and installer exe to you last Sunday.)

Thanks,

Phil

Bogdan
Posts: 2779
Joined: Tue Jul 07, 2009 7:34 am
Contact:

Re: MSI uninstall doesn't remove files

Post by Bogdan » Mon Aug 13, 2012 8:46 am

Hi Phil,

We got the logs by e-mail, unfortunately I could not find the mail with the aip file and executable, probably they were blocked because of the attached exe file.

Looking at the uninstall log I see the info code 1321, which means "The specified user account is not a member of the specified group account.", when the installer tries to uninstall the file "C:\Program Files (x86)\PicturePaste.com\PicturePaste 2\PicturePaste.exe", so it skips it. Have you applied any special permissions on the install folder?

Also, when you run the EXE I assume you are elevated from the beginning of the uninstall, does the elevation prompt appear when you launch the uninstall from Control Panel? Do you have UAC disabled on the machines?

Regards,
Bogdan
Bogdan Mitrache - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Centranthus
Posts: 4
Joined: Fri Aug 03, 2012 8:05 am

Re: MSI uninstall doesn't remove files

Post by Centranthus » Thu Aug 16, 2012 8:20 pm

Hi Bogdan,

I have just sent you the aip file and exe again, zipped up this time. Sorry, I should have done that the first time!

There are no special permissions on the install folders as far as I'm aware in any of the test cases we have tried.

I don't know whether the uninstall starts off elevated or not but it doesn't prompt for elevation at all when run from Control Panel. UAC is enabled at it's default setting on my test machine (Win7-64).

Phil

Cosmin
Posts: 5797
Joined: Tue Jul 10, 2007 6:39 pm
Contact:

Re: MSI uninstall doesn't remove files

Post by Cosmin » Fri Aug 17, 2012 1:45 pm

Hi Phil,

The problem you are encountering is caused by the installation type in Install Parameters page. It's per-user only and your package is installed in a per-machine location which requires Administrator privileges (Program Files). You did enable the "Run as administrator" option, but that affects only the EXE bootstrapper used during install. It doesn't work during uninstall or maintenance.

The correct approach is to change the installation type to per-machine or use a per-user install location, for example:

Code: Select all

[AppDataFolder][Manufacturer]\[ProductName]
Regards,
Cosmin
Cosmin Pirvu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Centranthus
Posts: 4
Joined: Fri Aug 03, 2012 8:05 am

Re: MSI uninstall doesn't remove files

Post by Centranthus » Fri Aug 17, 2012 1:58 pm

Hi,

Thanks for the suggested solution. I''l try it and let you know if it works.

Re. Difficulty reading emails: One of your emails to me was initially displayed using characters that I couldn't read. It was simply a problem of character encoding. I used Thunderbird's View | Character encoding menu to change to UTF-8 and then it was readable.

Phil

mihai.petcu
Posts: 3860
Joined: Thu Aug 05, 2010 8:01 am

Re: MSI uninstall doesn't remove files

Post by mihai.petcu » Mon Aug 20, 2012 10:34 am

Hi Phil,

UTF-8 encoding is very common for e-mails. You should keep that setting.

All the best,
Mihai
Mihai Petcu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Post Reply