Generic error duing install

Having trouble running Advanced Installer? Got a bug to report? Post it all here.
Post Reply
Bjammin
Posts: 23
Joined: Thu Jan 24, 2008 4:14 pm

Generic error duing install

Post by Bjammin » Fri Jan 08, 2016 9:21 pm

Have had thousands of good installs with Advanced Installer so I think this is a problem on a particular PC.

Error box says this & bails from install.

"There is a problem with this installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor."


I used to have a custom action, but I have removed that many months ago.

As requested I have attached the AIP & Log of the install. (The log had to be zipped to fit).

I think these are the lines that matter, but I'm not sure and either way I do not know how to fix this.

...
MSI (s) (E8:DC) [14:46:19:702]: Destroying RemoteAPI object.
MSI (s) (E8:38) [14:46:19:702]: Custom Action Manager thread ending.
MSI (c) (E4:CC) [14:46:19:702]: Back from server. Return value: 1603
MSI (c) (E4:CC) [14:46:19:702]: Decrementing counter to disable shutdown. If counter >= 0, shutdown will be denied. Counter after decrement: -1
MSI (c) (E4:CC) [14:46:19:702]: PROPERTY CHANGE: Deleting SECONDSEQUENCE property. Its current value is '1'.
Action ended 14:46:19: ExecuteAction. Return value 3.
MSI (c) (E4:CC) [14:46:19:702]: Doing action: FatalError
Action 14:46:19: FatalError.
Action start 14:46:19: FatalError.
Info 2826. Control BottomLine on dialog FatalError extends beyond the boundaries of the dialog to the right by 3 pixels.
Action 14:46:19: FatalError. Dialog created
MSI (c) (E4:2C) [14:46:25:349]: Doing action: AI_SHOW_LOG
Action 14:46:25: AI_SHOW_LOG.
Action start 14:46:25: AI_SHOW_LOG.
MSI (c) (E4:90) [14:46:25:349]: Invoking remote custom action. DLL: C:\Users\ccenter\AppData\Local\Temp\MSICD19.tmp, Entrypoint: LaunchLogFile
Action ended 14:46:25: AI_SHOW_LOG. Return value 1.
Action ended 14:46:25: FatalError. Return value 2.
Action ended 14:46:25: INSTALL. Return value 3.
MSI (c) (E4:CC) [14:46:25:521]: Destroying RemoteAPI object.
MSI (c) (E4:34) [14:46:25:521]: Custom Action Manager thread ending.
Property(C): CLIENTPROCESSID = 2276
...

Thank you for any assistance.
Attachments
CpsV5setup.aip
(206.96 KiB) Downloaded 153 times
CPS Install Log.zip
(174.07 KiB) Downloaded 93 times

Bjammin
Posts: 23
Joined: Thu Jan 24, 2008 4:14 pm

Re: Generic error duing install

Post by Bjammin » Fri Jan 08, 2016 9:23 pm

Also, this was run on Windows 7.

Eusebiu
Posts: 4835
Joined: Wed Nov 14, 2012 2:04 pm

Re: Generic error duing install

Post by Eusebiu » Mon Jan 11, 2016 11:16 am

Hi,

Looking over the log file I noticed that the "ActiveZip" custom action is the one that fails and I'm not sure why this happens. Can you reproduce the problem on multiple clean machine or outside the Advanced Installer package (i.e. from Command Prompt)?

Best regards,
Eusebiu
Eusebiu Aria - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Post Reply