Please wait while Microsoft configures Visual Studio Community 2015...

Having trouble running Advanced Installer? Got a bug to report? Post it all here.
mhatkinson
Posts: 31
Joined: Tue Apr 08, 2008 5:36 pm

Please wait while Microsoft configures Visual Studio Community 2015...

Postby mhatkinson » Fri Dec 01, 2017 1:41 am

Hi,
We're using version 12.4 of Advanced Installer.

Part way through building our project, we get a message box saying "Please wait while Microsoft configures Visual Studio Community 2015", then Advanced Installer hangs for 40 minutes or so.

Our project references some Visual C++ merge modules but, other than that, I can't think of anything. We've recently switched our build machine and this didn't happen on our older machine so I'm hoping it's just some files I need to install.

Is there anywhere in the project I can look to get an idea of why this is happening?

Daniel
Posts: 6533
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: Please wait while Microsoft configures Visual Studio Community 2015...

Postby Daniel » Wed Dec 06, 2017 3:30 pm

Hello,

This could happen if your Windows SDK installation became corrupted or some features are missing. During a setup package build including MSM packages we use the mergemod.dll library to merge the MSM content into the MSI installation database. So, you can try to reinstall the Windows SDK on your current machine and see if this helps.

Also, the mergemod.dll library should be registered on the system calling regsvr32 with a command line like this:

Code: Select all

regsvr32.exe mergemod.dll


All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube


Return to “Common Problems”

Who is online

Users browsing this forum: Bing [Bot], kundavaram and 2 guests