MSI 64-bit ProgramFiles (x86)

Having trouble running Advanced Installer? Got a bug to report? Post it all here.
rmoc
Posts: 6
Joined: Tue Mar 14, 2017 8:27 pm

MSI 64-bit ProgramFiles (x86)

Postby rmoc » Fri Dec 01, 2017 1:46 pm

I have created a 64Bit MSI package.
Settings.png
Settings.png (9.31 KiB) Viewed 40 times


But when I start the setup under Windows 10 (64Bit) the installation directory "C: \Program Files (x86)" is used.

Settings.png
Settings.png (9.31 KiB) Viewed 40 times


Why?

Daniel
Posts: 6535
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: MSI 64-bit ProgramFiles (x86)

Postby Daniel » Sat Dec 02, 2017 8:19 am

Hello,

I'm not so sure why this happens. Can you please send us the .AIP (project file) and a verbose log of the installation to support at advancedinstaller dot com so we can investigate them?

If you cannot share with us your project file, then you can try to isolate the behavior in a buildable sample (.aip + its referenced files) which we can build and test on our side.

Also, please try to give us a step by step test case too.

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

rmoc
Posts: 6
Joined: Tue Mar 14, 2017 8:27 pm

Re: MSI 64-bit ProgramFiles (x86)

Postby rmoc » Mon Dec 04, 2017 8:03 am

Hi Daniel,

Thank you for your answer. An example project is attached.

Regards,
René
Attachments
Your Application.aip
(15.93 KiB) Downloaded 1 time
logFile.txt
(213.81 KiB) Downloaded 1 time

Daniel
Posts: 6535
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: MSI 64-bit ProgramFiles (x86)

Postby Daniel » Wed Dec 06, 2017 3:47 pm

Hello René,

This happens because you are running the setup package built with "Build" buildname. Please note that the settings in our "Install Parameters" page must be set for each build included into your setup package.

Please proceed like this:

1. go to "Install Parameters" page and in the top toolbar select the "Install Parameters" tab
2. in the builds combo box select your "Build" build
3. set the package type for this build to 64-bit option too and rebuild the project

Test again the rebuilt setup package.

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube


Return to “Common Problems”

Who is online

Users browsing this forum: No registered users and 2 guests