Makepri.exe errors

Having trouble running Advanced Installer? Got a bug to report? Post it all here.
Post Reply
BillM
Posts: 19
Joined: Thu Jan 08, 2015 3:35 pm

Makepri.exe errors

Post by BillM » Wed Jul 11, 2018 8:17 pm

We've been using AI for years. Or project compiles just fine. We upgraded from 14.9 to 15.0 a week or two ago and immediately started getting the following errors during a build:

Checking builds status
Build required.

[ DefaultBuild ]
Failed to create priconfig.xml file.
Error details

Build finished because an error was encountered.

We went back to 14.9 and everything worked again. Now today I see 15.0.1 so I give it a try. Guess what? Makepri.exe errors again. Looks like I'm going back to 14.9 again.

Does anyone have any clue as to why Makepri.exe fails with 15.x but not 14.x?

If it matters, I have both Windows SDK 8 and 10 installed. AI sees v8 SDK for makepri and it won't let me change it. It sees v10 SDK for SignTool and Patch.

BillM
Posts: 19
Joined: Thu Jan 08, 2015 3:35 pm

Re: Makepri.exe errors

Post by BillM » Thu Jul 12, 2018 1:44 pm

Thanks for all the responses...

I fixed the issue by entirely removing Tile support from my project, since it was the tiles that required makepri in the first place. This isn't a great solution since I like the tiles and they've been in my project for at least a year now, but I need to ship our product and I can't count on AI deciding to arbitrarily fail on compile.

Dan
Posts: 4466
Joined: Wed Apr 24, 2013 3:51 pm

Re: Makepri.exe errors

Post by Dan » Thu Jul 19, 2018 8:53 am

Hello,

We have further continued this conversation over email and we found out that the problem is triggered when the project contains Tiles. We are not able to replicate the behavior on our end, but we will further investigate this issue.

It will help us greatly to provide a solution in the shortest possible time if we receive a buildable sample (.aip + its referenced files) that reproduce the described behavior and which we can build and test on our side.

Best regards,
Dan
Dan Ghiorghita - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

digocesar
Posts: 38
Joined: Thu Dec 03, 2015 12:26 pm

Re: Makepri.exe errors

Post by digocesar » Thu Sep 06, 2018 6:25 pm

Threre is a solution to this error?

Daniel
Posts: 8142
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: Makepri.exe errors

Post by Daniel » Tue Sep 11, 2018 1:49 pm

Hello,

Unfortunately we did not find any resolution by now to this issue as we are not able to replicate it on our end.

If you could help us with a step by step test case or small buildable sample which replicates the issue, this will be great.

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

digocesar
Posts: 38
Joined: Thu Dec 03, 2015 12:26 pm

Re: Makepri.exe errors

Post by digocesar » Wed Sep 12, 2018 3:45 pm

I sent a sample project to support_at_advancedinstaller.com.

Daniel
Posts: 8142
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: Makepri.exe errors

Post by Daniel » Mon Sep 17, 2018 2:52 pm

Hello,

Thank you for your sent files. I have tested and built the sent test project on several machines, but the build operation always succeeded.

Can you replicate this build error on multiple machines?

Also, can you try to reinstall (uninstall and install again) the Windows SDK on your current machine and see if this helps?

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

digocesar
Posts: 38
Joined: Thu Dec 03, 2015 12:26 pm

Re: Makepri.exe errors

Post by digocesar » Mon Sep 17, 2018 10:00 pm

My machine was with SDK 8.0 and 8.1 installed on it.
I did install SDK 10 and it solved the problem.

Daniel
Posts: 8142
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: Makepri.exe errors

Post by Daniel » Tue Sep 18, 2018 2:29 pm

Thank you for your follow up on this. Very useful your reply indeed.

We have further tested the build scenario on a machine with SDK 8 and 8.1 installed and were able to replicate the issue on our side too. Thank you for helping us to isolate the issue. A fix for this will be available in a future version of Advanced Installer.

We will update this forum thread as soon as the fix is out.

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Catalin
Posts: 3394
Joined: Wed Jun 13, 2018 7:49 am

Re: Makepri.exe errors

Post by Catalin » Wed Oct 17, 2018 3:33 pm

Hello,

This was fixed in version 15.4 of Advanced Installer released on October 17, 2018.

All the best,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

angus_oliver
Posts: 8
Joined: Thu Mar 20, 2014 1:33 pm

Re: Makepri.exe errors

Post by angus_oliver » Mon Oct 19, 2020 6:43 pm

I know this probably isn't relevant for the vast majority, but I had this issue today, after installing an older version (14.3) on a new laptop.

The answer for me I found on StackOverflow: https://stackoverflow.com/a/47015096/130230
This is what fixed it for me - download and install: http://download.microsoft.com/download/ ... KSETUP.EXE

Good luck!

Daniel
Posts: 8142
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: Makepri.exe errors

Post by Daniel » Tue Oct 20, 2020 7:16 am

Hi,

Thank you for sharing this solution with us.

Certainly this will be useful for other customers too.

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Post Reply