Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Having trouble running Advanced Installer? Got a bug to report? Post it all here.
Post Reply
madusmacus
Posts: 20
Joined: Mon Jul 25, 2011 3:12 pm

Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Post by madusmacus » Fri Feb 15, 2019 1:58 pm

Update: NEW INFO AT BOTTOM OF THREAD :¬)

In the issue list after the rebuild i get this message

The directory APPDIR is used by feature mainfeature , but there is no component refering to this directory
There is no automatic fix for this


I have used this project with 14.xx for years with no problem
I dont undertand the error message
Is it fatal

Please can someone help me
Mac
Last edited by madusmacus on Thu Feb 28, 2019 9:01 am, edited 3 times in total.

madusmacus
Posts: 20
Joined: Mon Jul 25, 2011 3:12 pm

Re: Please can i get help after upgrading from 14.xx to 15.7

Post by madusmacus » Fri Feb 15, 2019 2:17 pm

has this got anythign to do with it
sorry im totaly confused and on a release deadline

Image

Catalin
Posts: 1528
Joined: Wed Jun 13, 2018 7:49 am

Re: Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Post by Catalin » Mon Feb 18, 2019 8:52 am

Hello Mac,

Indeed, you are right. Starting with our 14.9 version of Advanced Installer this warning was added to avoid unpleasant situation when the APPDIR property is reset to default value on maintenance and uninstall mode. This happens when the following conditions are met:

1. no file resource is added under "Application Folder" directory (APPDIR property) from "Files and Folders" page
2. no component from "Organization" page is using the APPDIR property
3. at install time the "Application Folder" path is changed to a custom path, different than the default one set in "Install Parameters" page

When the above conditions are met, then when running the setup package on maintenance or uninstall mode the APPDIR property (Application Folder path) will be reset to the default path, thus the custom selected path at install time will be lost. This will cause problems with custom actions making use of the APPDIR property.

With that being said, if you have a custom action that is scheduled to run on Maintenance/Uninstall and that is making use of the APPDIR property, then you can proceed as it follows:

- go to "Files and Folders" page --> right click on "Application Folder" --> "Properties" --> check the "Create folder on target machine" option.

However, if you do not have any custom actions that runs on Maintenance/Uninstall and that is making use of the APPDIR property, then you can ignore that warning.

Hope this helps.

Kind regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

madusmacus
Posts: 20
Joined: Mon Jul 25, 2011 3:12 pm

Re: Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Post by madusmacus » Mon Feb 18, 2019 11:48 am

Hi Catalin

Thank you very much for the information

I tested install and uninstall on win7 and win10 using default and custom (user chosed) install directories and all seems to work fin as is
Although I belive this new warning it is not a problem (given we have used this for many years as is) I would like to get rid of the warning/error

My appologies for not totaly understanding whis APPDIR concept in the installer I have never had a reason to use it

Our installer requirements are very simple see below

Image

What would be achieved by just ticking the Create APPDIR box in the following image (to make the warnign go away)
I am sorry i dont understand because i have never used APPDIR and i am confused

Image

Many thanks
Mac

Catalin
Posts: 1528
Joined: Wed Jun 13, 2018 7:49 am

Re: Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Post by Catalin » Tue Feb 19, 2019 2:14 pm

Hello Mac,
Thank you very much for the information
You are always welcome. My pleasure to help.
My appologies for not totaly understanding whis APPDIR concept in the installer I have never had a reason to use it
No worries, that is why I am here. Please let me try to explain what APPDIR is:

First of all, let's try to explain what a Windows Installer Property is. Properties are global variables used by Windows Installer during an installation.

APPDIR is a Windows Installer property and it stores the installation path of your files. The default path of APPDIR can be seen in the "Install Parameters" page --> "Application folder:" field and it's default value is the following:

[ProgramFilesFolder][Manufacturer]\[ProductName]

where:

[ProgramFilesFolder] is a property that stores the following value: "C:\Program Files (x86)"

[Manufacturer] is a property that stores the value of the "Product Details" page --> "Publisher" field

[ProductName] is a property that stores the value of the "Product Details" page --> "Name" field

Properties.PNG
Properties.PNG (6.25 KiB) Viewed 1090 times
By default, in a newly created Advanced Installer project (without modifying anything), the APPDIR property has the following value:

C:\Program Files (x86)\Your Company\Your Application\

and this value changes in the moment a user chooses another installation directory:
APPDIR.PNG
APPDIR.PNG (24.13 KiB) Viewed 1090 times
Hope things are more clear now for you in what regards the APPDIR property.
I tested install and uninstall on win7 and win10 using default and custom (user chosed) install directories and all seems to work fin as is
I am glad this works for you. As I have stated in my previous thread, it only affects you in certain scenarios.

By checking that option, the APPDIR folder will be created and its value will be preserver during Maintenance/Upgrade.

Hope things are more clear for you now.

All the best,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

madusmacus
Posts: 20
Joined: Mon Jul 25, 2011 3:12 pm

Re: Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Post by madusmacus » Tue Feb 19, 2019 4:56 pm

Thank you for expanding on your previous explanation

My installer project seemed to remember this between runs anyway but...
I will tick it to make the warning go away i don think it can harm

Thanks

Catalin
Posts: 1528
Joined: Wed Jun 13, 2018 7:49 am

Re: Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Post by Catalin » Wed Feb 20, 2019 8:41 am

You're always welcome, Mac.

Yes, it should not affect your setup at all.

All the best,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

madusmacus
Posts: 20
Joined: Mon Jul 25, 2011 3:12 pm

Re: Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Post by madusmacus » Wed Feb 27, 2019 1:22 pm

Sorry more help needed here

There is definatly something wrong moving from 14 to 15 :¬(

If i tick the "Create folder on target machine" and rebuid the project.....
it make NO difference :¬(

After the "rebuild all" process it still complains after the build like i explained in previous posts (see image below)

Can you help me get rid of this its bugging the hell out of me

Image

Catalin
Posts: 1528
Joined: Wed Jun 13, 2018 7:49 am

Re: Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Post by Catalin » Fri Mar 01, 2019 10:43 am

Hello Mac,

This is really strange. I have tested this right now and the warning no longer appeared after I have checked the "Create folder on target machine" option.

In order for me to further investigate this, could you please send me a copy of your .AIP file by e-mail at support at advancedinstaller dot com?

All the best,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

madusmacus
Posts: 20
Joined: Mon Jul 25, 2011 3:12 pm

Re: Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Post by madusmacus » Fri Mar 01, 2019 10:59 am

Thank you for your help

I will do so now i have 2 aip that do this :¬)

the files will be in 2 zips setup1.zip and setup 2.zip

these aip projects have been throug many version upgrades of advanced installer i dont know if bit rot has set in due to this but they didnt show this warnign error in 14.5

Thanks again

UPDATE: sent email

Catalin
Posts: 1528
Joined: Wed Jun 13, 2018 7:49 am

Re: Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Post by Catalin » Mon Mar 04, 2019 1:34 pm

Hello Mac,

Thank you for the sent files. I have further investigated them but I could still not find the root cause of this (why the build error does not disappear when you choose to create the folder on the disk).

However, I have added a task to remove this message on our TODO list and hopefully it will no longer be shown in a future version of Advanced Installer.

I will update this thread as soon as it will be removed. Thank you for your patience.

All the best,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

madusmacus
Posts: 20
Joined: Mon Jul 25, 2011 3:12 pm

Re: Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Post by madusmacus » Fri May 17, 2019 1:14 pm

I waited a few releases and yesterday i istalled 15.9 to find that the problem i reported in this thread is still there :¬(

whilse it seems to have no impact on the final instal msi you did promis to fix it sometime after 15.7

any news on this?
Last edited by madusmacus on Sun May 19, 2019 11:22 am, edited 1 time in total.

Catalin
Posts: 1528
Joined: Wed Jun 13, 2018 7:49 am

Re: Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Post by Catalin » Fri May 17, 2019 3:17 pm

Hello Mac,

We are already working on this. Hopefully, this will be available in our next release (Advanced Installer 16.0).

I will update this thread as soon as this improvement will be available.

All the best,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

madusmacus
Posts: 20
Joined: Mon Jul 25, 2011 3:12 pm

Re: Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Post by madusmacus » Fri May 17, 2019 8:36 pm

Thank you for the fast feedback :) have a nice weekend all

Catalin
Posts: 1528
Joined: Wed Jun 13, 2018 7:49 am

Re: Upgraded from 14.x to 15.7 - New error in "Issue List" No auto fix

Post by Catalin » Mon May 20, 2019 7:43 am

You are always welcome, Mac.
:)

All the best,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Post Reply