Problems Re-packaging an EXE Using a Hyper-V VM

Having trouble running Advanced Installer? Got a bug to report? Post it all here.
Post Reply
BStearne
Posts: 4
Joined: Thu Mar 28, 2019 5:09 pm

Problems Re-packaging an EXE Using a Hyper-V VM

Post by BStearne » Thu Mar 28, 2019 5:17 pm

Still waiting to hear from Support on this one and i have exhausted my Google search skills. Can anyone point me in the right direction?

I am currently using Advanced Installer 15.8 - Architect version. I am following the tutorial located here (https://www.advancedinstaller.com/user- ... per-v.html) to make sure I am doing everything correctly. I have tried a good 10 times now trying different options. Mainly, changing the location the the 'Setup Path' under 'Packages'. The program and DOCS are not clear what path should be used (How does the VM get the application to run?).

Here is the output from my latest attempt. Any assistance would be greatly appreciated.

Connecting to Virtualization Product
Opening Virtual Machine: "TEP-APP_BUILD"
Checking snapshot operations compatibility
Connecting virtualization console
Reverting to Virtual Machine snapshot: "Automatic Checkpoint - TEP-APP_BUILD - (3/27/2019 - 8:43:05 AM)\Base Checkpoint"
Checking network connection
Powering on Virtual Machine
Checking Guest Integration Services on the guest operating system.
Logging in to Virtual Machine
Checking Advanced Installer Tools on the guest operating system
Advanced Installer Remote Tools are up-to-date.
Waiting for user login
Preparing Virtual Machine
Checking machine state
Running guest instance on the Virtual Machine
Failed to launch process! The system cannot find the file specified.
Cleaning up Virtual Machine
Closing current Virtual Machine session
An error occurred during the repack operation !

Eusebiu
Posts: 4558
Joined: Wed Nov 14, 2012 2:04 pm

Re: Problems Re-packaging an EXE Using a Hyper-V VM

Post by Eusebiu » Fri Mar 29, 2019 11:15 am

Hi and welcome to our forums.

From the log that appears during the repackage operation it seems to be a problem with the connection to the shared folder. In order to have more details, can you double-click the AI Remote Tools system tray icon that is displayed on the VM taskbar and tell me what is written in the "Logs" and the "Status" tabs?

Best regards,
Eusebiu
Eusebiu Aria - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

BStearne
Posts: 4
Joined: Thu Mar 28, 2019 5:09 pm

Re: Problems Re-packaging an EXE Using a Hyper-V VM

Post by BStearne » Fri Mar 29, 2019 6:21 pm

I completely restarted the process... letting Advanced Installer create a new VM in Hyper-V. Again, the same issue. There is nothing in the AI Remote Tools logs and the Status tab has the following:

Connection state: Service running and connected with User Application
IP Address: 169.254.89.211


The log from AI is below:

<< Advanced Repackager 15.8 build b14c769f44 >>

Connecting to Virtualization Product
Opening Virtual Machine: "TEP-APPBUILD"
Checking snapshot operations compatibility
Connecting virtualization console
Creating Virtual Machine snapshot: "AI_Before (7-Zip)"
Checking network connection
Powering on Virtual Machine
Checking Guest Integration Services on the guest operating system.
Logging in to Virtual Machine
Checking Advanced Installer Tools on the guest operating system
Advanced Installer Remote Tools are up-to-date.
Waiting for user login
Preparing Virtual Machine
Checking machine state
Running guest instance on the Virtual Machine
Failed to launch process! The system cannot find the file specified.
Cleaning up Virtual Machine
Reverting to Virtual Machine snapshot: "Initial snapshot\AI_Before (7-Zip)"
An error occurred during the repack operation !

Eusebiu
Posts: 4558
Joined: Wed Nov 14, 2012 2:04 pm

Re: Problems Re-packaging an EXE Using a Hyper-V VM

Post by Eusebiu » Tue Apr 02, 2019 12:33 pm

Hi,

It's strange that there is noting in the "Logs" section of the AI Remote Tools and the information from the "Status" tab is not really helpful.

Can you test the connection between your host and virtual machine (for example a ping to the IP address 169.254.89.211)?

Best regards,
Eusebiu
Eusebiu Aria - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

BStearne
Posts: 4
Joined: Thu Mar 28, 2019 5:09 pm

Re: Problems Re-packaging an EXE Using a Hyper-V VM

Post by BStearne » Thu Apr 04, 2019 3:23 pm

Narrowing down the problem...

I had the Advanced Installer Remote Tools window open before I started the repackaging session and saw this:

Adding network share connection for : \\10.10.5.158
Adding network share connection failed with error code : 53
Setting network share folders root for : \\10.10.5.158
Starting a new repackaging session

Okay... so the VM is having an issue accessing the share on my host machine (didn't realized it created one on the fly).

So, I created a new directory on my C: drive called !VM-Share and gave 'Everyone' Modify access to it and tried again. Still does not work.

I can ping the host from the VM, however I cannot manually connect to the share. Firewall and all of that nonsense disabled.

Running out of ideas.

BStearne
Posts: 4
Joined: Thu Mar 28, 2019 5:09 pm

Re: Problems Re-packaging an EXE Using a Hyper-V VM

Post by BStearne » Thu Apr 04, 2019 6:15 pm

More info...

The vSwitch in Hyper-V is set up as an 'External' switch (gets a real IP address and can see other network resources). I have also tried setting it up as an 'Internal' switch (VM can only communicate with the host). Same errors.

Is there any way to just have it attach to a network drive or some other kind of share to pull the file getting installed? Or, can I just put the installed files on the VM before I start the process?

Eusebiu
Posts: 4558
Joined: Wed Nov 14, 2012 2:04 pm

Re: Problems Re-packaging an EXE Using a Hyper-V VM

Post by Eusebiu » Mon Apr 08, 2019 3:33 pm

Hi,
Is there any way to just have it attach to a network drive or some other kind of share to pull the file getting installed? Or, can I just put the installed files on the VM before I start the process?
I'm afraid that this cannot be done.

Is your host part of a domain? Can you check if there is, somehow, a policy that blocks the access of the shared folders? Can you test if the repackager operation works from another local/virtual machine from the same network?

Best regards,
Eusebiu
Eusebiu Aria - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Testus_Maximus
Posts: 8
Joined: Tue May 21, 2019 12:39 pm

Re: Problems Re-packaging an EXE Using a Hyper-V VM

Post by Testus_Maximus » Tue May 21, 2019 12:43 pm

Hi there

I have the same issue. Here's my Log:

Adding network share connection for : \\169.254.178.14
Adding network share connection failed with error code : 53
Setting network share folders root for : \\169.254.178.14
Starting a new repackaging session
Adding intranet site : 169.254.178.14
Launch process : "\\169.254.178.14\AI_Home\bin\x64\RepackagerCLI.exe" /SetupPath "\\169.254.178.14\AI_App_0\ShareFileDriveMapper-v3.13.102.0.exe" /ProccesMonitor /CheckMachineState /ProductName "Citrix ShareFile Drive Mapper" /PromptAfterInstall /VmName "Test VM 2" /VmPath "3B8B7DA6-E25E-47D8-9609-B645DF369BBB" /GenerateBat /VmProfile "{60EFAF53-6EA9-4277-95FC-9005F65A8328}" /Configuration "MyProfile" /OutputPath "\\169.254.178.14\AI_Output" /VmServer "localhost" /VmHostType "2" /VmSlaveInstance
Elevation required, launch process elevated.
Failed to launch process! Das System kann die angegebene Datei nicht finden.

Best regards,
Maxi

Catalin
Posts: 1214
Joined: Wed Jun 13, 2018 7:49 am

Re: Problems Re-packaging an EXE Using a Hyper-V VM

Post by Catalin » Thu May 23, 2019 1:43 pm

Hello Maxi,

I have answered your forum thread here:

viewtopic.php?f=2&t=38235&p=105185#p105185

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Post Reply