Cannot set permissions for 'Everyone' on folder

Having trouble running Advanced Installer? Got a bug to report? Post it all here.
Post Reply
angus_oliver
Posts: 7
Joined: Thu Mar 20, 2014 1:33 pm

Cannot set permissions for 'Everyone' on folder

Post by angus_oliver » Sat May 11, 2019 7:02 pm

Using 14.3, I cannot set permissions on an installed folder for all users. The installer hangs, and never completes.
The folder is intended as a cache, and any user should be able to update all files within.
The folder is installed under 'Common Application Data', so somewhere under C:\ProgramData\CompanyName\App\
I can install the folder just fine, but when I add permissions, the installer fails.
permissions.png
permissions.png (13.83 KiB) Viewed 292 times
How do I successfully configure an installed folder to enable write access to all users?

Thanks!

Catalin
Posts: 1666
Joined: Wed Jun 13, 2018 7:49 am

Re: Cannot set permissions for 'Everyone' on folder

Post by Catalin » Mon May 13, 2019 11:10 am

Hello Oliver,

I have tested this right now and it works as intended. Did you run the setup as administrator? Please keep in mind that in order to modify a folder's permissions, you will need to provide elevated privileges.

Also, how do you verify if the permissions were correctly set? Did you go to the folder's location, right click on the folder -> "Properties" -> "Security" tab like in the attached screenshot?
Properties.PNG
Properties.PNG (18.01 KiB) Viewed 282 times
If that is the case, indeed, you may not see the permissions for "Everyone". However, if you click on the "Everyone" group and then click "Advanced", you will notice the permissions there like in the following screenshot:
Advanced.PNG
Advanced.PNG (36.64 KiB) Viewed 282 times
If that does not help, please forward me a copy of your .AIP file by e-mail at support at advancedinstaller dot com so I can further investigate this.

All the best,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

angus_oliver
Posts: 7
Joined: Thu Mar 20, 2014 1:33 pm

Re: Cannot set permissions for 'Everyone' on folder

Post by angus_oliver » Thu May 16, 2019 4:36 pm

Hi Catalin,

Thanks for your response..

I've spent a couple more days looking at it, and it seems there was actually no problem - I had a LOT of folders underneath that directory, and it was taking many, many minutes to apply the permissions. I assumed the installer had hung, whereas it was just trying as hard as it could to do what I asked it!

So - everything looks to be working as advertised 8-)
Thanks a lot for your help..!

-Angus

Catalin
Posts: 1666
Joined: Wed Jun 13, 2018 7:49 am

Re: Cannot set permissions for 'Everyone' on folder

Post by Catalin » Fri May 17, 2019 1:09 pm

Hello Angus,

You are always welcome. I am really glad you got this working.
:D

All the best,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Post Reply