XML search does not work.

Having trouble running Advanced Installer? Got a bug to report? Post it all here.
Post Reply
Chetan
Posts: 5
Joined: Fri May 24, 2019 12:12 pm

XML search does not work.

Post by Chetan » Fri May 24, 2019 12:34 pm

Hi!

I have a problem while performing a xml search while an upgrade. I am trying to preserve the value(s) from the previous installation.

In the attachment you will find the xml config file and a screen shot of the xml search.
If i test this search within Advanced Installer it gives me correct result, but during the actual upgrade installation this does not work and i get the default value. :roll:

Also while configuring the search i also noticed that the full node structure of the xml must be specified, even if i just want to read a perticular node.

Thank you in advance,
Chetan.

Note: I had to change the file name of My.config to My.config.xml, otherwise i got invalid file error while uploading it.
Attachments
My.config.xml
(1.67 KiB) Downloaded 8 times
Search.png
Search.png (90.39 KiB) Viewed 161 times

Catalin
Posts: 1248
Joined: Wed Jun 13, 2018 7:49 am

Re: XML search does not work.

Post by Catalin » Wed May 29, 2019 3:12 pm

Hello Chetan and welcome to Advanced Installer forums,

First of all, please accept my apologies for the delayed reply.

In what regards your the issue that you are facing, this may happen due to the fact that the [APPDIR] property is not resolved when the search is performed. Please keep in mind that the searches are performed right at the start of the installation process and the properties are resolved during the "CostFinalize" standard action.

With that being said, could you please try to implement the following step-by-step:

- please go to "Table Editor" page

- go to the "InstallUISequence"

- locate the "AI_XmlLocator" custom action and increase its sequence so it will be higher than the "CostFinalize" action's sequence. By default, the "AI_XmlLocator" will have its sequence equal to "101" and the "Cost Finalize" standard action has its sequence equal to "1000". For instance, you can set the "AI_XmlLocator" action's sequence to be equal to "1005".

and let me know if that helps?

Looking forward to hearing from you.

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Post Reply