jonnyo
Posts: 10
Joined: Tue Dec 10, 2019 9:26 am

Base64 Encoded String to Registry with Public Property

Tue Dec 10, 2019 9:45 am

Hi all,

we write a base64 encoded String to registry (with registry key method, no CustomAction). The value is inserted by Public Property on command line. The Problem is that containing "=" are replaced by " =" before the are written to registry.

An example:

we call following command line Setup.exe /q TEST_REGKEY="D083==" and the value is saved as "D083 = =". So blanks are inserted before "=".
So my Questions are:
1. Is this a Default behavior of MSI?
2. Is this a Problem with AI (Currently using 15.8)?
3. Should we set the value in another format by command line?
4. Are there any configurable switches within AI to resolve this Problem


I hope anyone of you has a hint for us to resolve this issue.

Thanks
Frank

Catalin
Posts: 4418
Joined: Wed Jun 13, 2018 7:49 am

Re: Base64 Encoded String to Registry with Public Property

Tue Dec 10, 2019 11:16 am

Hello Frank and welcome to Advanced Installer forums,
1. Is this a Default behavior of MSI?
No, it is not. The registry value should be written exactly as you have typed it in the command line.

I have done few tests on our end and everything worked as expected (with both AI 15.8 and AI 16.5).

In order for me to further investigate this, could you please forward me a copy of your .AIP file by e-mail at support at advancedinstaller dot com?

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Common Problems”