akshay karambale
Posts: 45
Joined: Thu May 28, 2020 8:04 am

Warning 4154 While adding Pre-intsall feature In EXE peoject

Thu May 28, 2020 9:13 am

Hello Danut Ghiorghita,

We have created an AI bootstrap package with some condition-based (added in the organization) feature-based pre-requisite. Let's assume Feature1.msi,Feature2.msi and Feature3.msi is a feature-based prerequisite added to the package.
And it is working as expected.
Now, when I'm adding one or more pre-install requisite with one install condition.
We are getting error for install as follows
Warning 4154, feature1 was not correctly installed, continue installation of bootstrap?
We have tried to resolve in different ways, but not able to resolve.
I have attached one sample project.
steps that i am followed,
1. Execute the SampleFeatureProject.exe
2. Next
3. Next
4. select Feature1 or Feature3 from combobox and Next
5. Install
6. it gives that error

Please let us know, what we are missing.

Thank you
Attachments
Prerequisites_2.zip
(986.59 KiB) Downloaded 202 times
Prerequisites1.zip
(1016.93 KiB) Downloaded 142 times
SampleFeatureProject.zip
(719.51 KiB) Downloaded 137 times

Dan
Posts: 4489
Joined: Wed Apr 24, 2013 3:51 pm

Re: Warning 4154 While adding Pre-intsall feature In EXE peoject

Fri May 29, 2020 12:04 pm

Hi Akshay,

You must make sure your prerequisite install conditions are correct from the conditions tab.
These conditions are evaluated two times:
- first to determine whether the prerequisite should be installed
- a second time, after the prerequisite has been installed, to determine whether the prerequisite install was successful
The reason you are receiving that warning is because the second time your conditions were evaluated, they failed. You should reevaluate your conditions for the prerequisite whose install was reported to have failed.

As I can see, one of the Pre-Install prerequisites have this install condition:

PrereqInstallCondition.PNG
PrereqInstallCondition.PNG (74.24 KiB) Viewed 4818 times

By the way, in the sent sample, one of the Pre-Install prerequisite is a .MSU file. Maybe Windows requires a reboot after installing that Windows Update. Can you please check if this is your case?

If you manually install that MSU file outside the installer, are you able to install the main package with just the 3 feature based prerequisite that could be successfully installed in the past?

Best regards,
Dan
Dan Ghiorghita - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube


akshay karambale
Posts: 45
Joined: Thu May 28, 2020 8:04 am

Re: Warning 4154 While adding Pre-intsall feature In EXE peoject

Mon Jun 01, 2020 2:27 pm

Hi ,

Thanks for the reply, I have gone through your reply, Yes there is some change in install condition i had did that change but still i am facing that issue.

Use case : If we are trying to install the plug-in(Feature.msi) then bootstrapper(exe) silently executes right UCRT(pre-install prerequisite) aplicable for windows7 and windows 8.1 only

I have also verified the install condition. Can you please help me out to solve this problem.
I have attached the updated sample project.
If you give some references it will really helpful for me.

Thanks in advance,
Akshay
Attachments
Prerequisites_2.zip
(986.59 KiB) Downloaded 139 times
Prerequisites1.zip
(1016.93 KiB) Downloaded 149 times
SampleFeatureProject.zip
(719.53 KiB) Downloaded 156 times

Dan
Posts: 4489
Joined: Wed Apr 24, 2013 3:51 pm

Re: Warning 4154 While adding Pre-intsall feature In EXE peoject

Wed Jun 03, 2020 7:09 am

Hello,

Can you please attach a printscreen with the erorr that you have during installation? Also a log file will help us a lot to have a better view about this. To crate a log, please check the how do i create a log article.

When you get that Warning 4154, can you please check if the prerequisite was correcly installed?

If the prerequisite was correctly installed, then the problem is with the install detection criteria that you have defined in the installer.

Maybe the prerequisite fails to install, thus the error message is correct.

Best regards,
Dan
Dan Ghiorghita - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

akshay karambale
Posts: 45
Joined: Thu May 28, 2020 8:04 am

Re: Warning 4154 While adding Pre-intsall feature In EXE peoject

Wed Jun 03, 2020 10:33 am

Hello,
Thanks for the reply, I get that 4154 error while installing the main package. I have also checked by installing stand alone pre-requisite, it correctly installed on my machine. But whenever i am trying to install any of the Feature msi from SampleFeatureProject.exe it gives me error of 4154.
I have attached the LogFile and screenshot of that error with this post.
Please let us know, what we are missing,

Thanks and Regards
Akshay
Attachments
LogFile.log
(319.05 KiB) Downloaded 147 times
Capture.JPG
Capture.JPG (38.92 KiB) Viewed 4776 times

Dan
Posts: 4489
Joined: Wed Apr 24, 2013 3:51 pm

Re: Warning 4154 While adding Pre-intsall feature In EXE peoject

Thu Jun 04, 2020 9:14 am

Hi,

As I said, this message is displayed when the install condition is not verified. Can you please let me know if the prerequisite was however installed? If the prerequisite was not installed, then the warning is correct.

To see why the prerequisite was not installed, please pass the following command line to the prerequisite:

prereq feature props.PNG
prereq feature props.PNG (11.98 KiB) Viewed 4767 times

This should create a log file on C:\ drive that should give us more details why the feature 2 prereq is not installed.

Best regards,
Dan
Dan Ghiorghita - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

akshay karambale
Posts: 45
Joined: Thu May 28, 2020 8:04 am

Re: Warning 4154 While adding Pre-intsall feature In EXE peoject

Thu Jun 04, 2020 1:09 pm

Hi,

I checked that pre-requisites are installed correctly if i execute it stand alone on, but whenever i am trying to install that using my bootstraper it gives me that error 4154.

I have explained the condition to install the Pre-requisite which helps you to get what is my exact requirement.

1. Operating system : Windows 7
Machine configuration : (UCRT Wind 7)pre-requisite is already installed on his machine
Feature1 : If user wants to install Feature1.msi then Bootstrapper install that Feature1 only.
(This case is Not Applicble for Feature2.msi and Feature3.msi)

Machine configuration : (UCRT Wind 7)pre-requisite is not installed on his machine
Feature1 : If user wants to install Feature1.msi then Bootstrapper first install that UCRT Wind7 pre-requisite and then install Feature1.
(This case is Not Applicble for Feature2.msi and Feature3.msi)

2. Oprating system : Windows 8
Machine configuration : (UCRT Wind 81)pre-requisite is already installed on his machine
Feature1 : If user wants to install Feature1.msi then Bootstrapper install that Feature1 only.
(This case is Not Applicble for Feature2.msi and Feature3.msi)

Machine configuration : (UCRT Wind 8)pre-requisite is not in his machine
Feature1 : If user wants to install Feature1 then Bootstrapper must install that UCRT Wind7 pre-requisite and then install Feature1.
(This case is Not Applicble for Feature2.msi and Feature3.msi)

3. Operationg system : other than Wind7 and Wind8
No need to install any of that Pre-requisite.
(Applicble for all feature1.msi , Feature2.msi and Feature3.msi)


I hope by reading this conditions you get clear idea of my requirement, If you still have any question you can ask me. Also i have attached the LogFile with this post. This issue is road blocking for us. It will be really helpful if we get a quicker solution on the same.

Best regards,
Akshay
Attachments
InstallFeature2.log
(128.91 KiB) Downloaded 144 times
InstallFeature1.log
(128.79 KiB) Downloaded 129 times

Eusebiu
Posts: 4894
Joined: Wed Nov 14, 2012 2:04 pm

Re: Warning 4154 While adding Pre-intsall feature In EXE peoject

Fri Jun 05, 2020 10:05 am

Hi Akshay,

My colleague, Dan, is not in the office, so I will continue this conversation with you.

I see that you try to install your feature-based prerequisites silently, but they need elevation for this and since they do not receive any elevation they fail in the background. In order to make sure they have admin rights, you need to go to the "Install Parameters" page of the main project and check the "Run as administrator" option.

Please test this and let us know if you still encounter problems.

Best regards,
Eusebiu
Eusebiu Aria - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

akshay karambale
Posts: 45
Joined: Thu May 28, 2020 8:04 am

Re: Warning 4154 While adding Pre-intsall feature In EXE peoject

Fri Mar 26, 2021 2:54 pm

hi Dan,
Is there any update regarding this Warning? We have still facing Warning 4154 and we have stuck at this stage. So, please solve this issue.

Thanks
Akshay

Eusebiu
Posts: 4894
Joined: Wed Nov 14, 2012 2:04 pm

Re: Warning 4154 While adding Pre-intsall feature In EXE peoject

Mon Mar 29, 2021 5:14 pm

Hi Akshay,

As we've already mentioned above, this warning is displayed if the prerequisites are not successfully installed or if their install conditions are not correct. Are you sure the above causes do not apply to your package? Can you remove the command line from the "Full UI" field of the prerequisite that fails and see if it gets installed that way?

Best regards,
Eusebiu
Eusebiu Aria - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Balaji
Posts: 45
Joined: Wed May 06, 2020 9:15 am

Re: Warning 4154 While adding Pre-intsall feature In EXE peoject

Tue Mar 30, 2021 9:18 am

Hi,
As per your suggestion, we have removed the command line from the "Full UI" field of the prerequisite.
And again tried to build and execute bootstrapper executable.
But, unfortunately this way is also not working. We are getting same warning 4154.

Please let me know your comment on this.

Thanks,
Balaji

Dan
Posts: 4489
Joined: Wed Apr 24, 2013 3:51 pm

Re: Warning 4154 While adding Pre-intsall feature In EXE peoject

Wed Mar 31, 2021 6:20 am

Hi Balaji,

If you're still gettting the 4154 warning, then the install condition criteria is not correct.

To avoid that message, you need to create an install condition that is met after prerequisite installation, e.g. a registry search. Maybe the related prerequisite will create some specific registries that you can use to detect if it was successfully installed or not.

Best regards,
Dan
Dan Ghiorghita - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

AKIKARAMBALE
Posts: 3
Joined: Mon Apr 20, 2020 12:37 pm

Re: Warning 4154 While adding Pre-intsall feature In EXE peoject

Wed Mar 31, 2021 12:13 pm

Hi Dan,
We have just added prerequisite not added any install condition by our own.
When we add prerequisite it automatically select "Install prerequisite based on conditions".
We have not given any condition.
We have built this project and try to run bootstrapper executable but getting same warning message.
Really don't know what is wrong with this project.

Also, really I did not understood below lines from your last reply.

" To avoid that message, you need to create an install condition that is met after prerequisite installation, e.g. a registry search. Maybe the related prerequisite will create some specific registries that you can use to detect if it was successfully installed or not. "

will you please elaborate it ?

Thanks,
Akshay

AKIKARAMBALE
Posts: 3
Joined: Mon Apr 20, 2020 12:37 pm

Re: Warning 4154 While adding Pre-intsall feature In EXE peoject

Wed Mar 31, 2021 1:08 pm

HI Dan,
will you please elaborate following lines from your last reply.
" To avoid that message, you need to create an install condition that is met after prerequisite installation, e.g. a registry search. Maybe the related prerequisite will create some specific registries that you can use to detect if it was successfully installed or not. "

We have not given any install condition by our own. We have just added prerequisite and tried to install that bootstrapper executable. But, getting same warning message.

Thanks,
Akshay

Return to “Common Problems”