Multi Disk Installer won't run from Disk

Having trouble running Advanced Installer? Got a bug to report? Post it all here.
Post Reply
shanna
Posts: 3
Joined: Tue Sep 15, 2020 2:17 pm

Multi Disk Installer won't run from Disk

Post by shanna » Tue Sep 15, 2020 2:30 pm

My installer spans 3 dual layer DVDs. I'm currently building with Advanced Installer v 15.2 and it's fine. My system prompts me for admin permissions, then runs the installer with no problem. . When I try to upgrade to the latest version of Advanced Installer, currently testing with 17.4.1, I am prompted for my admin permissions, then the installer just vanishes. No log is created when I have verbose logging enabled. If I run it from the hard drive it runs fine. It does not appear to be creating anything in the directory I'm running from. But it will not run from the disk.

If I create a single disk install, it runs from the disk no problem. But then I'm missing about two disks worth of data that needs to be included.
I can't find anything in the system logs about it.
I haven't changed anything in the .aip file between the two versions, except for the run where I tried to enable logging to get more info.

Stacie

Daniel
Posts: 8142
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: Multi Disk Installer won't run from Disk

Post by Daniel » Wed Sep 23, 2020 8:21 am

Hi Stacie and welcome to our forums,

Please accept our apologies for the delayed reply on this.

I cannot say why this happens. Can you please send us the .aip (project file) to support at advancedinstaller dot com so we can investigate its settings?

If you cannot share with us your project file, then you can try to isolate the behavior in a buildable sample (.aip + its referenced files) which we can build and test on our side.

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

shanna
Posts: 3
Joined: Tue Sep 15, 2020 2:17 pm

Re: Multi Disk Installer won't run from Disk

Post by shanna » Thu Sep 24, 2020 2:39 pm

I sent a version of the aip file to that address last Friday. It had some file renaming done in it, so it may not be perfect. If that was not sufficient, I'll try to create a mock up for you with none of our actual data by Monday.

Daniel
Posts: 8142
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: Multi Disk Installer won't run from Disk

Post by Daniel » Mon Sep 28, 2020 3:50 pm

Hi Stacie,

I am afraid the project file you have sent is actually corrupted. Most likely because you have manually edited its content outside Advanced Installer (e.g. into a text editor)?

If you cannot share with us the original project file, then please try to replicate the issue into a test or sample project so we can fully check and investigate is settings.

Thank you for your help on this.

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Daniel
Posts: 8142
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: Multi Disk Installer won't run from Disk

Post by Daniel » Tue Sep 29, 2020 11:32 am

Hi Stacie,

Thank you for helping us to isolate this issue.

I have tested the scenario and replicated the behavior.

Unfortunately this seems to be an issue that replicates in our newest versions of Advanced Installer. We will try to fix this in a future version of Advanced Installer, thank you for bringing this to our attention. We will notify you when the fix is out.

Until then, I am afraid the only workaround will be to build your multi disk installer project using the old version of Advanced Installer (15.2). Sorry for the inconvenience.

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

shanna
Posts: 3
Joined: Tue Sep 15, 2020 2:17 pm

Re: Multi Disk Installer won't run from Disk

Post by shanna » Tue Sep 29, 2020 1:32 pm

Got it. Thanks!

Daniel
Posts: 8142
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: Multi Disk Installer won't run from Disk

Post by Daniel » Wed Sep 30, 2020 5:34 am

You are always welcome.

Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Post Reply