ipollock
Posts: 99
Joined: Wed Aug 31, 2016 10:46 am

Applications and Virtual Directory showing root folder IIS

Wed Aug 04, 2021 5:06 pm

1. Built an installer for web applications.
2. Builds and installs fine
3. When i examine the IIS Tree on the left i see that the root folder containing apps (In file explorer) are also showing up as a virtual directory.

So in file explorer i have stored all the applications in 'WebAppRoot' as sub folders. When i create these in the IIS tab in Advanced Explorer
they look fine. Once this is installed into IIS, all of the applications show up ok as expected but the 'WebAppRoot' folder is also showing up
as a virtual folder even though it is not designed to be part of the IIS tree.

Can anyone tell me what i'm doing wrong? ;)
Thanks.

ipollock
Posts: 99
Joined: Wed Aug 31, 2016 10:46 am

Re: Applications and Virtual Directory showing root folder IIS

Wed Aug 04, 2021 5:41 pm

Is this because the application folder is also the root folder? If so, how would i get around this - i've also tried having an empty folder alongside but both are brought into the IIS tree...

ipollock
Posts: 99
Joined: Wed Aug 31, 2016 10:46 am

Re: Applications and Virtual Directory showing root folder IIS

Fri Aug 06, 2021 11:25 am

Ok, so figured this out - it was in the documentation and a little bit of trial and error. You have to set the install condition to (NOT Installed) for the root
and the rest goes in ok.
Hope this can be useful for others.
Attachments
IIS-Setup-Don't show root folders.PNG
IIS-Setup-Don't show root folders.PNG (22.77 KiB) Viewed 3911 times

Daniel
Posts: 8187
Joined: Mon Apr 02, 2012 1:11 pm
Contact: Website

Re: Applications and Virtual Directory showing root folder IIS

Tue Aug 10, 2021 8:48 am

Thank you for your follow up on this and for sharing the solution! Certainly this will be useful info for future customers!

Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Building Installers”