floch
Posts: 4
Joined: Wed Aug 23, 2023 12:19 pm

Make updater select patch for 1 level update and upgrade for old version

Tue Feb 27, 2024 8:30 am

Hi,
I am trying to setup a CLI pipeline that generates a update file that makes the updater use a patch if going from 1.18 to 1.19 and full upgrade if going from any earlier version than 1.18.
So far I can create a upgrade project that adds both the patch file and the full upgrade file however I can't see how we can make the updater choose the correct one.

Catalin
Posts: 6580
Joined: Wed Jun 13, 2018 7:49 am

Re: Make updater select patch for 1 level update and upgrade for old version

Mon Mar 04, 2024 4:54 pm

Hello,

In order to achieve what you want, you could try using the "Update Targets" tab from your Updates Configuration project.

By doing so, you can make the patch target a specific version and then the major upgrade target another specific version.

Hope this helps!

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Building Installers”