frankmanguiob
Posts: 7
Joined: Fri May 08, 2020 6:46 pm

AppData\Roaming

Fri May 29, 2020 1:25 pm

Hi,

I noticed just now that every major upgrade I build and install, there's an msi extracted/generated in the folder mentioned. In particular, C:\User\AppData\Roaming\<Manufacturer>\<ProductName> <ProductVersion>\install\. I understand if this is used for self-repair, but it does not get deleted every time a new version is installed.

Same goes for the uninstaller registry entry in CurrentVersion/Uninstall. Each version I install adds a new entry here, with key name as <ProductName> <ProductVersion>. Obviously this is less of a concern as there are less resources taken up by this.

I just want to know what setting controls these, and how to ensure these get deleted on uninstall.

Thanks!

Catalin
Posts: 4224
Joined: Wed Jun 13, 2018 7:49 am

Re: AppData\Roaming

Tue Jun 02, 2020 11:03 am

Hello Frank,
I noticed just now that every major upgrade I build and install, there's an msi extracted/generated in the folder mentioned. In particular, C:\User\AppData\Roaming\<Manufacturer>\<ProductName> <ProductVersion>\install\. I understand if this is used for self-repair, but it does not get deleted every time a new version is installed.
Indeed, when building an EXE package, at install time, the MSI and the CAB files are extracted (by default) in the following location:

Code: Select all

[AppDataFolder][|Manufacturer]\[|ProductName] [|ProductVersion]\install
Also, by default, they are deleted when the installation is over. However, you might have checked the "Do not delete extracted MSI and CAB files" option.

You can find this option in "Builds" page --> "Bootstrapper Options".

Hope this helps.

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

frankmanguiob
Posts: 7
Joined: Fri May 08, 2020 6:46 pm

Re: AppData\Roaming

Wed Jun 03, 2020 3:12 am

Hi Catalin,

Yeah it's unchecked.

I tried rebuilding, installing then uninstalling and the folder's still there.

Also, if I install a major upgrade, this should delete for the previous version as well, right?

Thanks.

Catalin
Posts: 4224
Joined: Wed Jun 13, 2018 7:49 am

Re: AppData\Roaming

Fri Jun 05, 2020 12:53 pm

Hello Frank,
Yeah it's unchecked.
This is indeed strange. The MSI and the CAB file should be deleted at the end of the installation, unless that option is checked.

I have tested this just now and everything seemed to be working as expected. The MSI and CAB files are extracted when I launch the setup and deleted at the end of the installation process.

Could you please try to test this on a clean machine (e.g. a Virtual Machine with a fresh install of Windows) and let me know if this is reproducible?

Additionally, could you please let me know which Advanced Installer version you are using? I have tested this using the latest version of Advanced Installer - v17.1.1.

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

SimLoe
Posts: 51
Joined: Thu Mar 12, 2020 11:37 am

Re: AppData\Roaming

Fri Apr 30, 2021 9:55 am

Hello Catalin,

I think I encountered the same issue. If I understood correctly @frankmanguiob did not say that the files are being kept, but a lot of empty folders. At least this is what I encounter. For every installed Version, I have a folder with the name of the version and this folder only contains one folder called "install". This folder itself is empty.
Folders.png
Folders.png (41.01 KiB) Viewed 3825 times
I don't have the option "Do not deleted extracted CAB and MSI files" enabled and those files are not being kept. However there are a lot of empty folders. For me, it looks like those empty folders also should be deleted after the setup.

Best regards,

Simon

Catalin
Posts: 4224
Joined: Wed Jun 13, 2018 7:49 am

Re: AppData\Roaming

Thu May 06, 2021 8:25 pm

Hello Simon,

I have tested this, but I was not quite able to reproduce this on my end - the folders are always removed from the %appdata% folder.

Could you please provide a test-case which I can follow in order to reproduce this issue? Or, if possible, please send me a sample project that reproduces this by e-mail at support at advancedinstaller dot com so I can further investigate this.

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

SimLoe
Posts: 51
Joined: Thu Mar 12, 2020 11:37 am

Re: AppData\Roaming

Fri May 07, 2021 7:27 am

Hello Catalin,

I just sent you the requested files.
Looking forward to your answer!

Best regards,
Simon

Catalin
Posts: 4224
Joined: Wed Jun 13, 2018 7:49 am

Re: AppData\Roaming

Fri May 07, 2021 5:16 pm

Hello Simon,

Thank you for the provided resources!

Based on your project, I have created a sample project in which I have been able to reproduce this behavior.

I have forwarded this to our development team and hopefully this will be fixed in a future version of Advanced Installer.

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Catalin
Posts: 4224
Joined: Wed Jun 13, 2018 7:49 am

Re: AppData\Roaming

Tue May 18, 2021 12:06 pm

Hello Simon,

After further investigations and discussions with our development team, it looks like this is happening because the MSI handles are not properly closed, resulting in the folder being left on the disk.

To avoid this, please go to "Install Parameters" page and set the following property:
AICloseAllHandles.png
AICloseAllHandles.png (6.36 KiB) Viewed 3551 times

This way, the extraction folder should be properly removed after the install process.

Hope this helps!

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

SimLoe
Posts: 51
Joined: Thu Mar 12, 2020 11:37 am

Re: AppData\Roaming

Wed May 19, 2021 8:36 am

Hello Catalin,

I tried your suggestion, but it did not work. The empty folder ist still there. Please give it a try with the setup files I provided for you. I added the parameter and nothing has changed on this side.

Please have a look at it again.

Best regards,
Simon

Catalin
Posts: 4224
Joined: Wed Jun 13, 2018 7:49 am

Re: AppData\Roaming

Thu May 20, 2021 5:01 pm

Hello Simon,

Thank you for your followup on this!

I am sorry to hear it did not help.

Unfortunately, I can not really test this on my end (with your setup) because I can not pass the property through command line (since it is not a public property).

What I did, however, was building your project using dummy resources (this is a feature in our debug version) and then deploying the setup. The folder was created and then removed when the installation ended, as expected.

What I have noticed when doing so is the fact that you have multiple builds in your project. Please make sure you have included the property in the correct build.

If everything is fine regarding that, please forward me a new download link for the setup (where you have set that property) so I can have a look over it once again.

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

SimLoe
Posts: 51
Joined: Thu Mar 12, 2020 11:37 am

Re: AppData\Roaming

Fri May 21, 2021 7:28 am

Hi Catalin,

I just sent the requested files via email.
Please let me know if you need further information.

Best regards,
Simon

Catalin
Posts: 4224
Joined: Wed Jun 13, 2018 7:49 am

Re: AppData\Roaming

Wed May 26, 2021 1:57 pm

Hello Simon,

Thank you for the provided resources.

I have run the setup on my machine and everything worked as expected - i.e. the folder was removed when the installation ended.

I would assume this has something to do with your developer machine, if you are testing on it. Could you please try testing this on a clean machine and let me know if you are able to reproduce it?

Also, please note that it is recommended testing your setup on a clean machine.

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

SimLoe
Posts: 51
Joined: Thu Mar 12, 2020 11:37 am

Re: AppData\Roaming

Wed May 26, 2021 3:16 pm

Hello Catalin,

I tried it on two different clean machines, both had this empty folder left over.
Are you sure that this folder was deleted after setup? Did you look for the right company name?

Looking forward to your answer,

Simon

Catalin
Posts: 4224
Joined: Wed Jun 13, 2018 7:49 am

Re: AppData\Roaming

Thu May 27, 2021 2:42 pm

Hello Simon,
Are you sure that this folder was deleted after setup? Did you look for the right company name?
Yes, I have been looking for the "Product Details" page --> "Publisher" folder.

Here is a screenshot before installation:
BeforeInstall.png
BeforeInstall.png (54.59 KiB) Viewed 3316 times

And here is a screenshot after the installation:
AfterInstallation.png
AfterInstallation.png (30.84 KiB) Viewed 3316 times

As you can see, the folder is correctly removed.

The steps I'm taking would be:

- launch the setup

- "Typical" installation

Perhaps your test-case is different?

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Building Installers”