Not can't figure out Why the fwk 4.5.2 is installed if is not as a pre-requisit

Ask a question, request an improvement or report a bug.
bottonTurn
Posts: 5
Joined: Wed Mar 28, 2018 3:36 pm

Not can't figure out Why the fwk 4.5.2 is installed if is not as a pre-requisit

Postby bottonTurn » Fri Jun 22, 2018 9:23 pm

Hi all, thanks to read this, and try to help me.

This is the scenario, I have a project that check pre-requisite at the lunch condition, the condition is:

NETFRAMEWORK452, and validate if fwk 4.5.2 is or not insaller, so if is not installer then show Microsoft .NET Framework 4.5.2 or greater is required.

this works fine when I have an .msi, lunch the message but, when I run installation form a .exe I not get the message and some thing worst, install me the fwk 4.5.2.

Also, I see that, even if the fwk 4.5.2 is installed the installed change in some way, because the msi logs generates log that the fwk was change.

If I look into the logs when the fwk is installed I get:
Condition 'NETFRAMEWORK45 >= 379893' evaluates to false.

Is this a condition that the fwk have to be installed or have to not be installed?, I google and some blogs says you "should install fwk" in some similar issues when install an application but they dont have that fwk version, but in my case i already have installed, why advancedinstaller try to re-install again or tuch it?

this is very important, because I change the fwk of our customer... :(

Best regards, and thanks again.

Daniel
Posts: 7417
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: Not can't figure out Why the fwk 4.5.2 is installed if is not as a pre-requisit

Postby Daniel » Fri Jun 29, 2018 12:51 pm

Hello,

This could happen if the setup package of .Net Framework is also configured as a prerequisite for your setup package.

Can you please go to "Prerequisites" page and check if you have added any .Net Framework prerequisite item? A prerequisite will be always installed when the install conditions from its "Install Conditions" tab are not fulfilled.

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

bottonTurn
Posts: 5
Joined: Wed Mar 28, 2018 3:36 pm

Re: Not can't figure out Why the fwk 4.5.2 is installed if is not as a pre-requisit

Postby bottonTurn » Tue Aug 07, 2018 9:56 pm

Hi, I don't have anything in prerequisites page, but I have a lunch condition set like attachment image.

I am more confuse right now :cry:

this are line from installation log,

Code: Select all

[09FC:10C0][2018-06-26T02:34:41]i000: Setting string variable 'NETFRAMEWORK45' to value '1'
Then it checks to make sure NETFRAMEWORK45 (1) is >= 379893 which returns false:
[09FC:10C0][2018-06-26T02:34:41]i052: Condition 'NETFRAMEWORK45 >= 379893' evaluates to false
.

then

Code: Select all

[09FC:10C0][2018-06-26T02:34:41]i201: Planned package: NetFx452Web, state: Absent, default requested: Present, ba requested: Present, execute: Install, rollback: None, cache: Yes, uncache: No, dependency: None


and

Code: Select all

[09FC:1C48][2018-06-26T02:34:52]i338: Acquiring package: NetFx452Web, payload: NetFx452Web, download from: http://go.microsoft.com/fwlink/?LinkId=397707
[2A38:20B8][2018-06-26T02:34:53]e000: Error 0x800b0003: Failed authenticode verification of payload: C:\ProgramData\Package Cache\.unverified\NetFx452Web
[2A38:20B8][2018-06-26T02:34:53]e000: Error 0x800b0003: Failed to verify signature of payload: NetFx452Web
[2A38:20B8][2018-06-26T02:34:53]e310: Failed to verify payload: NetFx452Web at path: C:\ProgramData\Package Cache\.unverified\NetFx452Web, error: 0x800b0003. Deleting file.
[2A38:20B8][2018-06-26T02:34:53]e000: Error 0x800b0003: Failed to cache payload: NetFx452Web
[09FC:1C48][2018-06-26T02:34:53]e314: Failed to cache payload: NetFx452Web from working path: C:\WINDOWS\TEMP\{11c40815-86d0-44ca-a048-59519a9d3edf}\NetFx452Web, error: 0x800b0003.
[09FC:1C48][2018-06-26T02:34:53]e349: Application requested retry of payload: NetFx452Web, encountered error: 0x800b0003. Retrying...



Ok, I have a few questions, why the installer trying to download NetFx452Web if the computer already has fwk 4.5.2?, and why or were is defined this url http://go.microsoft.com/fwlink/?LinkId=397707 ?? I search in setup.aip (open file as a text file and search reference to that url and is not defined there)

thanks for your help.
Attachments
lunchcond.PNG
lunchcond.PNG (9.36 KiB) Viewed 1197 times

Daniel
Posts: 7417
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: Not can't figure out Why the fwk 4.5.2 is installed if is not as a pre-requisit

Postby Daniel » Sun Aug 12, 2018 7:54 pm

Hello,

I am not sure why this happens. To get a complete view of your installation scenario, can you please send us the .aip file and a verbose log of the installation to support at advancedinstaller dot com so we can fully investigate this on our side?

If you cannot share with us your project file maybe you can isolate the behavior in a small sample project.

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

bottonTurn
Posts: 5
Joined: Wed Mar 28, 2018 3:36 pm

Re: Not can't figure out Why the fwk 4.5.2 is installed if is not as a pre-requisit

Postby bottonTurn » Tue Aug 28, 2018 9:45 pm

Hi Daniel, thank for answer, I will send you the verbose log, the .aip I can't since I ask form a large application that use advancedinstaller and share that information is not possible.

Also i found something new, the .msi install process not have that problem, only occurs in .exe, since the .exe is a wrapper for .msi can't think what is going on..

I will try to share ASAP

thanks,

Daniel
Posts: 7417
Joined: Mon Apr 02, 2012 1:11 pm
Contact:

Re: Not can't figure out Why the fwk 4.5.2 is installed if is not as a pre-requisit

Postby Daniel » Wed Aug 29, 2018 8:08 am

Hello,

The only configuration I am aware that could generate this behavior is when the .Net Framework 4.5.2 setup package is added as a pre-installed prerequisite into your setup project. The pre-installed prerequisite are supported only by our EXE package type and installed only when using the EXE package type.

If you cannot share with us the AIP (project file), then please try to isolate the behavior into a sample project configured with similar settings like the original one and send it us so we can fully test this.

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube


Return to “Installer Analytics”

Who is online

Users browsing this forum: No registered users and 2 guests