atark
Posts: 1
Joined: Wed Jun 09, 2021 1:06 pm

Problem with windows.protocol and certification in Windows Store

Wed Jun 09, 2021 2:24 pm

Hello!
We have been building an installer for Windows Store (MSIX_APPX). We need to open our app from browsers by specified uri scheme. So we added Declaration "windows.protocol". We specified custom Restarter.exe file as executable. This file is placed near our main executable in APPDIR.
When build is complete we have .msixupload as a result. In this bundle I see several appx's. Structure of the bundle is:
bundle_files.JPG
bundle_files.JPG (27.4 KiB) Viewed 5259 times
Main-x86.appx contains manifest where our declaration (windows.protocol) specified:

Code: Select all

<uap:Extension Category="windows.protocol" EntryPoint="Windows.FullTrustApplication" Executable="Restarter.exe">
          <uap:Protocol Name="ourschema">
            <uap:DisplayName>Restarter</uap:DisplayName>
            <uap:Logo>Assets\StoreLogo.png</uap:Logo>
          </uap:Protocol>
</uap:Extension>
There is only our main executable (not Restarter) in main appx.
When we try to upload generated msixupload to Windows Store we receive an error:
error: Manifest validation error: Line 39, Column 94, Reason: The file name "Restarter.exe" declared for element "*[local-name()='Applications']/*[local-name()='Application']/*[local-name()='Extensions']/*[local-name()='Extension' and not(@Category='windows.backgroundTasks' or @Category='windows.appService')]" doesn't exist in the package.
I suppose that Windows Store validator tries to find Restarter.exe in main package and doesn't find it.
So, how can we avoid this issue? Can we place Restarter.exe to main package? Can we stop separating our bundle to main packages and asserts? Or maybe there is another way?

Thank you

Catalin
Posts: 4330
Joined: Wed Jun 13, 2018 7:49 am

Re: Problem with windows.protocol and certification in Windows Store

Mon Jun 14, 2021 4:03 pm

Hello and welcome to our forums,

If I understand your scenario correctly, the problem is that your executable is not added to your package (please correct me if I'm wrong)?

I have done a test regarding this using two executables and both were added to my setup:
TwoExes.png
TwoExes.png (31.78 KiB) Viewed 5235 times

If the file is not added to your main package, is it added elsewhere?

Looking forward to hearing from you.

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Building Installers”