cmconti
Posts: 6
Joined: Mon Mar 04, 2024 5:00 pm

updated .net release prerequisites

Microsoft patches/releases updated .net versions more frequently than AI is updated. e.g. AI 21.5 added support for the pre-defined .net 8.0.2, but since then 8.0.3 has been released.

https://www.advancedinstaller.com/user- ... sites.html says that after a predefined prerequisite has been added to an installer, its setting can be modified.

In this case, is:
- add 8.0.2 from the check list
- update:
1. the display name
2. the file path of the downloaded runtime exe (after manually downloading the 8.0.3 installer and replacing the older 8.0.2 one)
3. the required minimum version
the correct steps for setting 8.0.3 as the version to install?

It appears to work, though it gave me pause that in the list of frameworks and runtimes 'predefined prerequisites', 8.0.2 remains checked. I'm assuming the logic behind that page is to either check for >= or just major.minor since only a single version of each .net major release is listed
Catalin
Posts: 6727
Joined: Wed Jun 13, 2018 7:49 am

Re: updated .net release prerequisites

Hello,

As you mentioned, sometimes it is hard to keep up with the speed at which these packages are released, despite trying our best.

If you want to add the latest version to your Advanced Installer project, you can proceed similarly to how you mentioned:

- add the newer version manually as a prerequisite

- you can create a new project in which you add the version 8.0.2 so you can copy the install conditions and then change those in your main project

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Building Installers”