Erapchu
Posts: 6
Joined: Wed Aug 03, 2022 4:29 am

GitHub Advanced Installer issues

Recently I automated build of .aip project using GitHub actions. I used that https://www.advancedinstaller.com/autom ... tions.html
And all is stuck, I waited for 1 hour and cancelled job. I'm tried v21.6.1 and now upgraded to v21.7.1.

GitHub action:
- name: Build installer x64
uses: caphyon/advinst-github-action@v1.0
with:
advinst-version: ${{ env.ADVINST_VERSION }}
advinst-license: ${{ secrets.ADVINST_LICENSE_KEY }}
advinst-enable-automation: 'true'
aip-path: ${{ github.workspace }}\Installer\eFiler.Sync.aip
aip-build-name: MSI_x64
aip-package-name: eFiler.Sync.x64.${{ env.GitBuildVersionSimple }}.msi
aip-output-dir: ${{ github.workspace }}\Installer\SetupFiles\
aip-commands: |
SetProductCode -langid 1033

What am I doing wrong?

No any error was returned. Locally all is working fine - aip is building correctly
Attachments
Снимок экрана 2024-05-14 111040.png
Снимок экрана 2024-05-14 111040.png (42.8 KiB) Viewed 681 times
Erapchu
Posts: 6
Joined: Wed Aug 03, 2022 4:29 am

Re: GitHub Advanced Installer issues

Changed product version option to always generate a product code (first option) and all is going fine on github
Thanks to Catalin Gheorghe
Catalin
Posts: 6730
Joined: Wed Jun 13, 2018 7:49 am

Re: GitHub Advanced Installer issues

You are alwyas welcome!

Glad I was able to assist. :D

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Common Problems”