Henrique Mesquita
Posts: 11
Joined: Thu Apr 27, 2023 12:22 pm

FAILURE TO UPDATE VIA COMMAND LINE AFTER VERSION 20.7.1

Good morning,

Before reporting the incident, I would like to describe how our application currently operates:

We have a MAIN application that installs other applications configured under the "Prerequisites" tab, installed via command line with necessary properties. Upon installation, the folder architecture is as follows:

Image

Example command line for installing one of the prerequisites:

/exenoui /qn APPDIR="[APPDIR]\PreRequisiteName" WORKFOLDER="[WORKFOLDER]\PreRequisiteName" TENANTNAME="[TENANTNAME]" ORGANIZATIONNAME="[ORGANIZATIONNAME]" PROXYADDRESS="[PROXYADDRESS]" PROXYPORT=[PROXYPORT] ENABLEPROXY=[ENABLEPROXY] AUTHPROXY=[AUTHPROXY] PROXYUSER=[PROXYUSERNAMECRIPTO] PROXYPASSWORD=[PROXYPASSWORDCRIPTO] ENABLEGATEWAY=[ENABLEGATEWAY] GATEWAYADDRESS=[GATEWAYADDRESS] GATEWAYPORT=[GATEWAYPORT]

For further details on how we use this, here is a link: viewtopic.php?t=52086 to a previous topic we created (please disregard the incident reported in that topic and focus only on the explanation of how our application works).

Incident:

We upgraded Advanced Installer from version v20.7.1 to v21.8.2 and encountered the following issue:

When performing an update via command line, the properties passed in the "Prerequisites" tab are not transferred at runtime. Consequently, only the MAIN application is installed without the prerequisites.

Below is a log screenshot from an update performed using an installer generated in version 21.8.2 and executed via command line:

Image

An important point is that this issue occurs only when the update is done via command line. Using the same package via the UI, the update succeeds in installing both the main application and its prerequisites.

With the installer generated in version 20.7.1, the command line update works correctly. Reviewing the log at the same point as before, it's evident that the property value is correctly passed:

Image

Command line executed for update:

APP_1.0.0.exe /quiet

We've noticed some changes in the prerequisites tab interface. We've researched and made several adjustments, but none have been successful. Reverting to version 20.7.1 or earlier resolves the issue.

Could you assist us with this adjustment? Since the Advanced Installer interface has changed, there might be another configuration we haven't found, or perhaps this is indeed a bug.

Thanks.
Eusebiu
Posts: 4942
Joined: Wed Nov 14, 2012 2:04 pm

Re: FAILURE TO UPDATE VIA COMMAND LINE AFTER VERSION 20.7.1

Hi,

Indeed, the "Prerequisite" support was redesigned starting with version 20.9 of Advanced Installer which added some benefits, but also came with this limitation. Namely, when the main package is EXE and it is installed with basic UI or in silent mode, the properties set in the command line field are not sent to the post-install prerequisite (prerequisite added after the main package).

We've already reported this issue to the development team so they will look into this and try to find a solution for a future version of Advanced Installer.

In the meantime, you can overcome this problem by creating an MSI main package instead of EXE or by sticking to an old version of Advanced Installer until a fix is implemented.

Best regards,
Eusebiu
Eusebiu Aria - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube
Henrique Mesquita
Posts: 11
Joined: Thu Apr 27, 2023 12:22 pm

Re: FAILURE TO UPDATE VIA COMMAND LINE AFTER VERSION 20.7.1

Good afternoon,

Thank you for your response.

We conducted tests by installing the prerequisites before the main package, and the scenario remained the same, with no values in the properties.

Do you have an estimate for when the incident will be fixed/released? We need to use some functions that are available in the new versions but we are stuck on 20.7.1.
We cannot use the main package as MSI because we require the language selection screen.

Thank you again.

Best regards,
Henrique Mesquita
Eusebiu
Posts: 4942
Joined: Wed Nov 14, 2012 2:04 pm

Re: FAILURE TO UPDATE VIA COMMAND LINE AFTER VERSION 20.7.1

Hi Henrique,
We conducted tests by installing the prerequisites before the main package, and the scenario remained the same, with no values in the properties.
In this case, the main package has not yet been executed and none of its custom properties can be sent to the prerequisite.
Do you have an estimate for when the incident will be fixed/released? We need to use some functions that are available in the new versions but we are stuck on 20.7.1.
I'm afraid that I cannot say for sure when this improvement will be available, neither if we will be able to find a solution, but we will update this thread when we will have a resolution.

Best regards,
Eusebiu
Eusebiu Aria - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Common Problems”