xxtang
Posts: 5
Joined: Sun Aug 30, 2009 1:50 pm

Why I receive "An error occurred while extracing"?

Mon Aug 31, 2009 6:41 am

I am a new user of Advanced Installer,the software version is 7.1.3.
But when I new a enterprise project , and set "Create EXE setup file " in Media and builded it, I have encounted the problem.
An error dialog message popped with saying "An error occurred while extracting".
I don't know how to resolve it?
Thank you!
Attachments
1.JPG
The error image
1.JPG (7.23 KiB) Viewed 8546 times

xxtang
Posts: 5
Joined: Sun Aug 30, 2009 1:50 pm

Re: Why I receive "An error occurred while extracing"?

Mon Aug 31, 2009 8:13 am

This circumstances occurred after I runed the Patch of McAfee antivirus software, before that it's wok.

GabrielBarbu
Posts: 2146
Joined: Thu Jul 09, 2009 11:24 am
Contact: Website

Re: Why I receive "An error occurred while extracing"?

Mon Aug 31, 2009 12:11 pm

Hello,

Although not sure, it seems McAffe is interfering with some part of the extract process. You should check your McAffe's security policy and make sure it is not blocking your executable installer.

Regards,
Gabriel
Gabriel Barbu
Advanced Installer Team
http://www.advancedinstaller.com/

xxtang
Posts: 5
Joined: Sun Aug 30, 2009 1:50 pm

Re: Why I receive "An error occurred while extracing"?

Wed Sep 02, 2009 3:16 am

Though I unistalled the McAfee antivirus software, the Advanced Installer still can't work.
And I found a miraculous phenomenon:
When I reboot the computer, before all the service start, I builded the .aip at once, promptly.
The miracle occurred, The error disappeared.
However, all the service and software started quickly, when I rebuilded the .aip, "An error occurred while reading the file".
All the things happened just a while, and order to do this experiments, I reboot the computer several times.
I don't know which service or sofrware interfere Advanced Installer normal work.
And I want to know the Advanced Installer require what kind of conditions to work with "Create the EXE setup file"

GabrielBarbu
Posts: 2146
Joined: Thu Jul 09, 2009 11:24 am
Contact: Website

Re: Why I receive "An error occurred while extracing"?

Wed Sep 02, 2009 9:45 am

Hi,

It appears some services may be conflicting with Advanced Installer. You can use the services.msc tool to disable non-Windows services to see which one is conflicting with Advanced Installer. Please let us know if you found any services that conflict with Advanced Installer so we can further look into this matter.

Thank you,
Gabriel
Gabriel Barbu
Advanced Installer Team
http://www.advancedinstaller.com/

demontagu
Posts: 3
Joined: Mon May 24, 2010 3:54 pm

Re: Why I receive "An error occurred while extracing"?

Mon May 24, 2010 4:28 pm

Hello,

I use Advanced Installer v 7.3.1
I receive "An error occurred while extracting" on Windows Server 2008 x64 SP2 Enterprise (there are no problems on other OS)

Some investigation here:
Advanced Installer is installed (and install .exe prepared) on a machine with Regional settings: language for non-unicode programs - "Russian"

I got error on target machine with language for non-unicode programs - "English (US)"
There is no error if language for non-unicode programs changed to "Russian" with reboot.

Cosmin
Posts: 5797
Joined: Tue Jul 10, 2007 6:39 pm
Contact: Website

Re: Why I receive "An error occurred while extracing"?

Tue May 25, 2010 4:14 pm

Hi,

When are you receiving this error? Also, can you reproduce it when using the latest version (7.6.1)?

Regards,
Cosmin
Cosmin Pirvu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

demontagu
Posts: 3
Joined: Mon May 24, 2010 3:54 pm

Re: Why I receive "An error occurred while extracing"?

Tue May 25, 2010 4:38 pm

Hello Cosmin,

I receive this error immediately when I run .exe install file (created by advanced installer) on Windows 2008 Server machines. So no files were extracted, etc.
The same with the latest 7.6.1

Below are some notes around this issue.

It doesn't matter where I create install file XP or Vista in any langs including English (US).
The problem reproduces only on Win 2008 with next conditions:
1) Prepare any exe install with Advanced Installer on any system.
2) On Windows 2008 Sp2 select English (US) locale in Regional Settings
3) On Windows 2008 Sp2 create a user with name contained non-english letters (no matter admin or standard user)
4) Log on with that user
5) Run exe prepared on stage 1 - you will get the error

But if I change locale to which one contained symbols of the user name the problem will gone.

Another steps:
3) Place the install file from stage 1 to a path contained non-english letters and run exe - the same error.

Cosmin
Posts: 5797
Joined: Tue Jul 10, 2007 6:39 pm
Contact: Website

Re: Why I receive "An error occurred while extracing"?

Wed May 26, 2010 7:46 am

Hi,

Is Windows 9x supported in the "Launch Conditions" page? If so, please uncheck it. This way the installer will use the Unicode bootstrapper, so paths which Unicode characters should be supported. If this doesn't solve the problem, can you please send us the .AIP (project) file you are using to support at advancedinstaller dot com so we can investigate it?

Regards,
Cosmin
Cosmin Pirvu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

demontagu
Posts: 3
Joined: Mon May 24, 2010 3:54 pm

Re: Why I receive "An error occurred while extracing"?

Thu May 27, 2010 9:38 am

cosmin wrote:Is Windows 9x supported in the "Launch Conditions" page? If so, please uncheck it
It works now! Thanks a lot Cosmin.

dzar
Posts: 10
Joined: Tue Apr 04, 2006 3:15 am

Re: Why I receive "An error occurred while extracing"?

Thu Mar 31, 2011 3:09 am

I'm having this same problem but nothing here seems to fix it. I have lots of projects that all work, but one does not. Anything new to check? I'm running version 8.0.2.

Thanks,
Dave

mihai.petcu
Posts: 3860
Joined: Thu Aug 05, 2010 8:01 am

Re: Why I receive "An error occurred while extracing"?

Thu Mar 31, 2011 1:45 pm

Hi Dave,

Can you please upgrade to 8.1 and see if the problem persists?

Best,
Mihai
Mihai Petcu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

dzar
Posts: 10
Joined: Tue Apr 04, 2006 3:15 am

Re: Why I receive "An error occurred while extracing"?

Thu Mar 31, 2011 2:59 pm

Yep, works now!

Thanks... just got my email notification of the new version an hour after reading this. :D

jasoncd
Posts: 43
Joined: Thu Jan 29, 2009 4:48 pm

Re: Why I receive "An error occurred while extracing"?

Tue Apr 12, 2011 5:06 pm

Is there a specific problem that was addressed in 8.1? Our install is failing on a client's 2008 R2 64-bit system. We would need to purchase a new maintenance plan to get 8.1, so I would like to be reasonably sure that 8.1 would fix the problem. Thanks.

mihai.petcu
Posts: 3860
Joined: Thu Aug 05, 2010 8:01 am

Re: Why I receive "An error occurred while extracing"?

Wed Apr 13, 2011 1:21 pm

Hello,
Our install is failing on a client's 2008 R2 64-bit system.
Can you please give us more details about this behavior? You can also use the trial version to verify if our latest release fixes this problem.

The 8.1 version and its follow-up 8.1.1 have new features, many improvements and bug fixes. For a complete list please follow this web page. We also have the 8.1.2 and 8.2 coming up very soon.

All the best,
Mihai
Mihai Petcu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Common Problems”