Patrick8639
Posts: 5
Joined: Tue May 29, 2018 8:34 am

Problem for an MSI installer

Mon May 25, 2020 3:44 pm

Hello,
I'm trying to create an MSI installer for a .NET Core WPF application, as you can see in the first screenshot, the UI is not great:
- The title of the main dialog displays "Installation de de membres": the "de" text is repeated.
- The top displays "0K0" instead of a text.
- The background of the licence check box doesn't have the right background color.
- The icon on the text box doesn't have the right background.

msi.png
The installer, when the MSI output is selected
msi.png (33.16 KiB) Viewed 1150 times

If I use the exe version of the installer, the display is better, but the main window has no title...

My application uses .NET Core 3.1.4, that is not available in your prerequisites... Why there is no a setting where we can manually specify which version of the .NET Core we want to install if not available? We can't wait, when a new version of .NET Core is available, for you to update your prerequisite list in order to support it.

Finally, the text during installation is displayed in light gray over a white background... Not readable at all.

To summarize, I cannot use your installer, that I paid, to install this application!

Catalin
Posts: 4400
Joined: Wed Jun 13, 2018 7:49 am

Re: Problem for an MSI installer

Mon May 25, 2020 4:13 pm

Hello Patrick,

In what regards the UI problems you are encountering, this is most probably happening because you are using a theme that requires the "Enhanced User Interface" (available for .EXE packages) option in order to render its elements.

If I'm not mistaken, the theme you are using is the "Surface" theme. Please note that in order to use this theme, the .EXE package ("Builds" page --> EXE package) together with the "Enhanced User Interface" option ("Themes" page --> "Settings" tab --> "User Interface" section).

If you want to build an MSI, please use any of the "Classic" themes ("Themes" page --> "Preview" tab).
My application uses .NET Core 3.1.4, that is not available in your prerequisites... Why there is no a setting where we can manually specify which version of the .NET Core we want to install if not available? We can't wait, when a new version of .NET Core is available, for you to update your prerequisite list in order to support it.
In what regards this, please note that you can always add any package you want as a prerequisite in Advanced Installer.

All you need to do is to go to "Prerequisites" page --> right click on appropriate stage (in our case, since the prerequisite is ".NET Core", we will need to add it as a pre-install prerequisite) --> "New package prerequisite ..." and then select the installation package for your prerequisite.

Additionally, you will need to develop the install condition(s) for your prerequisite ("Prerequisites" page --> your prerequisite --> "Install Conditions" tab).

Fortunately, you can use the conditions we have used for previous versions (such as ".NET Core Runtime 3.1.3") as a starting point.

Additionally, I will add this on our TODO list and we will try to provide a predefined prerequisite for ".NET Core Runtime 3.1.4" as soon as possible. Thank you for bringing this to our attention.

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Catalin
Posts: 4400
Joined: Wed Jun 13, 2018 7:49 am

Re: Problem for an MSI installer

Tue Jun 09, 2020 10:35 am

Hello,

This improvement has been implemented in Advanced Installer 17.1, released on May 27th, 2020.

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Common Problems”