a.guelle
Posts: 81
Joined: Tue May 19, 2015 2:23 pm

[solved] "Invalid URL format...." in OpenURL Action with dynamic properties

Tue Aug 25, 2020 3:45 pm

Hi Everyone,

Min. AI 16.3 - 17.3 does not allow properties in the Open URL action.

Best regards,

Angelo
Attachments
2020-08-25_16h40_32.png
2020-08-25_16h40_32.png (4.21 KiB) Viewed 1376 times
Last edited by a.guelle on Thu Oct 08, 2020 10:07 am, edited 1 time in total.

a.guelle
Posts: 81
Joined: Tue May 19, 2015 2:23 pm

Re: "Invalid URL format...." in OpenURL Action with dynamic properties

Wed Aug 26, 2020 2:20 pm

Can anyone from AI confirm the behaviour? This prevents us from using any version higher than AI 15.

Daniel
Posts: 8187
Joined: Mon Apr 02, 2012 1:11 pm
Contact: Website

Re: "Invalid URL format...." in OpenURL Action with dynamic properties

Mon Aug 31, 2020 7:29 am

Hi Angelo,

We investigated on this and indeed this seems to be an issue of our "Custom Actions" page UI. A fix for this issue will be available in a future version of our product, thank you for bringing it to our attention. When the fix will be released we will update this forum thread.

Until then, as a workaround, you can use our "Table Editor" feature (available only in our Enterprise and Architect edition of Advanced Installer).

Just go to "Table Editor" page and select the "CustomActions" table. Select the row of your OpenUrl action and set its "Target" column like this:

Code: Select all

http://localhost:[HTTP_PORT_PROP]/centrax/...
Then save and rebuild your setup project.

Hope this helped.

All the best,
Daniel
Daniel Radu - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Catalin
Posts: 4418
Joined: Wed Jun 13, 2018 7:49 am

Re: "Invalid URL format...." in OpenURL Action with dynamic properties

Thu Oct 01, 2020 4:08 pm

Hello,

This has been fixed in version 17.5 of Advanced Installer, released on September 22nd, 2020.

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

a.guelle
Posts: 81
Joined: Tue May 19, 2015 2:23 pm

[solved] "Invalid URL format...." in OpenURL Action with dynamic properties

Thu Oct 08, 2020 10:06 am

Works like a charme,

thank you for pushing this into the release.

Catalin
Posts: 4418
Joined: Wed Jun 13, 2018 7:49 am

Re: [solved] "Invalid URL format...." in OpenURL Action with dynamic properties

Thu Oct 08, 2020 4:21 pm

You are always welcome, Angelo!

I am glad everything works as expected now.

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Common Problems”