andyeaust
Posts: 15
Joined: Mon Mar 05, 2018 10:14 am

Feature based Prerequisites not installing on silent install

Fri Sep 28, 2018 10:01 am

Hello Community,
we have a package with some feature based prerequisites.
When we run the Setup.exe in Full-UI, all prerequisites are installing properly. We think that it worked on older Release of AI. At the Moment we use AI 15.3.

When we use Silent install NO feature based prerequisites are installed.
We read the FAQ https://www.advancedinstaller.com/user- ... uestion122 and test the available Solutions but Nothing helped.

We made a new test-project, add the prerequisites with no other files and no special Installation behaviors. It's the same. It runs in FullUI but not silent.
We test what happened when we remove the install command lines for Silent (no UI) of the feature based prerequisite. Then we get an error at Installation:
error.PNG
We look at https://www.advancedinstaller.com/user- ... uestion134
Because of this we check the download/extraction Folder of the prerequsite, it's the default "[AppDataFolder][|Manufacturer]\[|ProductName]\prerequisites"
Also we check the build extraction Location "[AppDataFolder][|Manufacturer]\[|ProductName] [|ProductVersion]\install"
We also make a msi log and check it with "Wilogutl.exe" but can't find any errors.

We ca send you a complete test Project, but it's About 175MB.
In Atachement you get a test AIP

PS: It's the same if we install only "build in" feature based prerequsites like c++ 2010 Runtime x86.

Thanks for your Help,
Andreas

andyeaust
Posts: 15
Joined: Mon Mar 05, 2018 10:14 am

Re: Feature based Prerequisites not installing on silent install

Fri Sep 28, 2018 2:40 pm

I check something else:
i found this article viewtopic.php?f=2&t=34927

With AI 15.3 it's not working with the /q

I made a additional Test-Project with 15.01:
The prerequesites are installing with the /q silent Parameter.
But: If i add there a prerequiste with "Additional Files" None of the prerequisites are installing… mhhh..
I remove this prerequisite, it works.

I opened the 15.01 Project with 15.3 and make a build:
No prerequisites are installed

I think there must be something wrong with silent Installation in the 15.3 and something with additional files in the 15.01

Catalin
Posts: 4324
Joined: Wed Jun 13, 2018 7:49 am

Re: Feature based Prerequisites not installing on silent install

Fri Sep 28, 2018 3:29 pm

Hello Andreas,

I am not sure why this happens.

In order for me to further investigate this, can you please send us a copy of your .AIP file (project file) that reproduces this behavior and a download link for the setups you are trying to add as "Feature-Based" prerequisites by e-mail at support at advancedinstaller dot com?

Kind regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Catalin
Posts: 4324
Joined: Wed Jun 13, 2018 7:49 am

Re: Feature based Prerequisites not installing on silent install

Mon Oct 01, 2018 3:29 pm

Hello Andreas,

I have tested your scenario and indeed, you are right, the "Feature-Based" prerequisites are not installed when the main package is installed silently. This seems to be an issue in what regards Advanced Installer.

A fix will be available in a future version of Advanced Installer.

All the best,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

andyeaust
Posts: 15
Joined: Mon Mar 05, 2018 10:14 am

Re: Feature based Prerequisites not installing on silent install

Tue Oct 02, 2018 8:25 am

Hello Catalin,

thanks for your Reply.
We have the Problem, that our main Installer not working at the Moment because of this Is there a chance to Downgrade our AIP Project to 14.9?
Because we have a important bugfix delivery to our customers and we have no backup :cry: of the old aip.

Regards
Andreas
Last edited by andyeaust on Tue Oct 02, 2018 11:10 am, edited 1 time in total.

Catalin
Posts: 4324
Joined: Wed Jun 13, 2018 7:49 am

Re: Feature based Prerequisites not installing on silent install

Tue Oct 02, 2018 8:34 am

Hello Andreas,

Unfortunately, it is not possible to downgrade your AIP project to 14.9.

It is considered a best practice to always have your files backed up and Advanced Installer also automatically creates a backup when you build your project using a newer version.

Thank you for your understanding.

All the best,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

andyeaust
Posts: 15
Joined: Mon Mar 05, 2018 10:14 am

Re: Feature based Prerequisites not installing on silent install

Tue Oct 02, 2018 11:17 am

OK,
i see the AIP backup Files from the older Versions. But when i open one backupfile with the older Version i get the Message:
"This Project (Fragment) was editetd with a newer Version of Advanced Installer (15.3) and cannot be loaded"

What data i have to backup to can go down to an older release.

Aditionaly: What time we have to plan for a new AdvancedInstaller Release which fix the Problem.

Catalin
Posts: 4324
Joined: Wed Jun 13, 2018 7:49 am

Re: Feature based Prerequisites not installing on silent install

Tue Oct 02, 2018 1:39 pm

Hello Andreas,

That error occurs when the backup .aip project was also edited / re-built with the 15.3 version of Advanced Installer. I am afraid there is no way you can open your project with 14.9 version now, since the backup file was re-built using a newer version.
Aditionaly: What time we have to plan for a new AdvancedInstaller Release which fix the Problem.
In what regards this, unfortunately, I can not give you any estimation, but I will update this thread as soon as a fix will be available.

Thank you for your understanding!

All the best,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Catalin
Posts: 4324
Joined: Wed Jun 13, 2018 7:49 am

Re: Feature based Prerequisites not installing on silent install

Wed Oct 17, 2018 3:19 pm

Hello,

This was fixed in version 15.4 of Advanced Installer released on October 17, 2018.

All the best,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Common Problems”