Reggie
Posts: 2
Joined: Mon Feb 28, 2022 9:44 am

Advanced installer silent updater.exe not running as a service

Hello,

I'm trying to update my software silently as described here: https://www.advancedinstaller.com/user- ... dater.html
Whenever I click on the updater.exe manually on my machine, my product gets updated just fine. But when I run it in the Task Scheduler, I get a response code of: 0xE0000011.
When I ran the Task as my logged in user account, the update was successfully but when I set the permission on SYSTEM I get the same response code as before and the update didn't succeed.
I want to set my permission on SYSTEM because I want to run the updater whenever any user logs in.

Thanks in advance,

Reggie
Catalin
Posts: 6786
Joined: Wed Jun 13, 2018 7:49 am

Re: Advanced installer silent updater.exe not running as a service

Hello Reggie and welcome to our forums,

The code the Updater returns in your case means:
No updates are available for the application or there are no updates matching /justcheck filters
as per our "Updater return codes" article.

If you require any further assistance regarding running the Updater under the SYSTEM account, please have a look over the following article my colleague Dan has created:

Install updates without elevation, automatically at user logon

Hope this helps!

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube
Reggie
Posts: 2
Joined: Mon Feb 28, 2022 9:44 am

Re: Advanced installer silent updater.exe not running as a service

Hi Catalin,

I followed all the tutorials but nothing seems to work. I always get the same response code in the task scheduler: 0xE0000011
That means no updates have been found and everything is up to date even though the new update is online.
Whenever I check it manually, the updates can be found and install successfully.

Do you have any idea how and why I can't auto update my product silently but when I manually run updater.exe it works?
I use the Enterprise edition and work on a 64 bit Windows 10.

Edit: I also see this in the updater.log:

# 2022-03-02 09-55-13 [PID=19856|Thread=22208] | To many parametes for updater service. Expecred 2. Transmited: 1 Params: updater LastError: 3758096416
Catalin
Posts: 6786
Joined: Wed Jun 13, 2018 7:49 am

Re: Advanced installer silent updater.exe not running as a service

Hello Reggie,

This is indeed strange.

In order for me to further investigate this, could you please forward me the following resources:

- a copy of the .AIP file

- a copy of the Updater project

- a download link for the older version of your setup (the one that can be upgraded through the Updater)

by email at support at advancedinstaller dot com?

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube
moz02
Posts: 1
Joined: Fri Dec 09, 2022 1:12 pm

Re: Advanced installer silent updater.exe not running as a service

Hi,

I am seeing the same area running a /silentall -nofreqcheck update. Did this issue ever get resolved? I have the updater on scheduled task which runs once and updates fine but throws the error as above. Then it never seems to be able to update again from the task again.

Thanks,
Catalin
Posts: 6786
Joined: Wed Jun 13, 2018 7:49 am

Re: Advanced installer silent updater.exe not running as a service

Hello and welcome to our forums,

Is your scenario the same as the previous user's, i.e. does this work when you manually run the updater.exe?

Additionally, could you please let me know what error code you're encountering? You could check this in the "Event Viewer".

As previously mentioned, in order for me to further investigate this, could you please forward me the following resources:

- a copy of the .AIP file

- a copy of the Updater project

- a download link for the older version of your setup (the one that can be upgraded through the Updater)

by email at support at advancedinstaller dot com?

Best regards,
Catalin
Catalin Gheorghe - Advanced Installer Team
Follow us: Twitter - Facebook - YouTube

Return to “Common Problems”