Requirements

Hardware

Advanced Installer System Requirements

Minimum

  • Core 2 class CPU
  • 1 GB RAM
  • 1366x768 screen resolution
  • 2 GB hard drive space

Software

Advanced Installer IDE

The following software must be installed on your system in order for Advanced Installer to run correctly:

  • Windows 7 or newer
  • Latest Windows Platform SDK (optional, required only to build certain types of packages)

Create Install Packages

The MSI or EXE install files that Advanced Installer produces run on the following operating systems:

  • Windows Vista or newer
  • Windows Server 2008 or newer

Create MSIX Packages

The MSIX packages that Advanced Installer produces run on the following operating systems:

  • Windows 10 version 1507 or newer
  • Windows Server 2016 (Long Term Servicing Channel) version 1607 or newer

For Java

Advanced Installer for Java has the ability to create install bundles to install Java programs on the following versions of Mac OS:

  • Mac OS X 10.x PowerPC
  • Mac OS X 10.x Intel

Windows 10 Compatibility

Both Advanced Installer and the EXE/MSI install packages it creates are tested and run on Windows 10.

Windows 10 is fully supported by the latest Advanced Installer release.

Legacy Advanced Installer Versions

To use Advanced Installer IDE on a development machine running Windows XP SP3 or Vista install Advanced Installer 12.0.

To use the Visual Studio 2010 Extension, install Advanced Installer 13.6 or older.

To create MSI or EXE packages that run on:

  • Windows XP SP3 and Windows Server 2003 download Advanced Installer 15.9
  • Windows XP SP2 download Advanced Installer 12.5
  • Windows 95/98/ME/NT4/2000 download Advanced Installer 10.3