Working with Advanced Installer Projects

The Advanced Installer Project is an XML file with the extension AIP. Advanced Installer provides several mechanisms for managing your installation project. These mechanisms can be accessed using toolbar buttons, the application main menu and keyboard accelerators.

Creating a new project

New Project Use the [ New... ] toolbar button, the “File > New...” menu item or the Ctrl+N keyboard shortcut. The Start Page will show up.

Loading an existing project

Open ProjectUse the [ Open... ] toolbar button, the “File > Open...” menu item or the Ctrl+O keyboard shortcut. You can also load an existing project by double clicking on the corresponding AIP project file in Windows Explorer.

Loading a recently accessed project

Use the “File > Recent Projects >” sub menu or select the project from the Start Page.

Saving the project

Save Project Use the [ Save ] toolbar button, the “File > Save” menu item or the Ctrl+S keyboard shortcut.

Saving the project under a different name

Use the “File > Save as...” menu item.

Warning!Warning: starting a new project from an already existing one by saving it under a different name is not advisable, because all the GUIDs for product, components, etc. in the two projects will be identical and thus will conflict. You should use the “File > Save as Template...” option for this.

Save As Template...

Use the “Save As Template...” menu item.

Creates a project template starting from the current project in order to reuse it in building a different package. New UpgradeCode, ProductCode and all the components GUIDs are generated when the template is used.

Building the project

Build ProjectUse the [ Build ] toolbar button, the “Project > Build” menu item or the F7 keyboard shortcut. You need at least one component (file, registry entry, etc) in your project before you can build it.

You have the option to select which build to perform from the button's drop down menu. When you directly push the button, the project that was build last is created. If no individual build was made previous, all builds are performed.

ImportantBy default, Advanced Installer caches the archives created during build process in order to reuse them in future builds if the source files did not change.

Running the project

Run Project Use the [ Run ] toolbar button, the “Project > Run” menu item or the F5 keyboard shortcut. If the project is out of date, it will first be built and then launched.

When this button is used, the resulted package from the last performed build is launched. If all the builds were performed than the first package in the building order is launched.

Running the project with logging enabled

Enable the “Show run log” item “Home” tab in the ribbon. The resulting Windows Installer log will be shown in the “Run Log” Panel.

Running the project in a virtual machine

Use the “Run in VM” item of the [ Run ] button context menu or the “Project > Run > Run in VM” menu item. You can test the installation by running it in the provisioned virtual machine.

Displaying context-sensitive help

Run ProjectUse the [ Help ] toolbar button, the “Help > Context Help” menu item or press the F1 key. Certain pages may also have embedded help displayed by default in their unused screen space. You can turn off the embedded help from the “View > Embedded Help” menu item.