Advanced Installer Main Menu

Warning!This article is deprecated, for the latest Advanced Installer user interface documentation see the Ribbon page.

The menu bar gives you access to all the features of Advanced Installer, some of them not available from the toolbar. It contains the following sub menus: “File”, “View”, “Installation”, “Project”, “Wizards”, “Options” and “Help”.

Main Menu

The File menu

  • New... - allows you to create a new project. The Start Page will be displayed.
  • Open... - opens an existing project (.AIP). Also opens built installer database files (.MSIs) in MSI Quick-Edit mode.
  • Recent Projects - opens one of the most recently opened or created projects.
  • Save - saves the current project.
  • Save As... - saves the current project under a different name.
  • Save As Template... - creates a project template starting from the current project in order to reuse it in building a different package. New UpgradeCode, ProductCode and all the components GUIDs are generated when the template is used.
  • Import
    • Visual Studio Project... - imports a Visual Studio Project into an Advanced Installer project.
    • Updates Configuration File... - imports an already created Updates Configuration File into an Advanced Installer Updates Configuration Project.
    • Import MSI/MSM... - imports an MSI/MSM file into a existing Advanced Installer project.
    • Eclipse Workspace... - imports the projects from an Eclipse workspace into an existing Advanced Installer project.
    • IntelliJ IDEA Workspace... - imports the projects from an IntelliJ IDEA workspace into an existing Advanced Installer project.
  • Exit - closes the application.

The View menu

  • Tool Bar - shows or hides the toolbar.
  • Status Bar - shows or hides the status bar.
  • Only Non-Empty Views - hides left pane entries for pages were nothing was modified in the project.
  • Left Pane > - opens a sub menu with two items:
    • Show - shows or hides the left pane.
    • Large Icons - shows large or small icons in the left pane page menu.
  • Lock the toolbars - locks or unlocks the toolbars
  • Navigate Backward - navigate back in the project. You can also use the [ Navigate Backward ] toolbar button or press the Alt + Left keyboard shortcut.
  • Navigate Forward - navigate forward in the project. You can also use the [ Navigate Forward ] toolbar button or press the Alt + Right keyboard shortcut.
  • Go To Last Change - navigate to the last location where the project was modified. You can also use the [ Go To Last Change ] toolbar button or press the Alt + Down keyboard shortcut.
  • Info Panes >
    • Log Pane - shows or hides the log pane.
    • Issues Pane - shows the results of the ICE validation process.
    • References Pane - displays a list with the references of the item you have tried to delete.
    • Find Result Pane - displays the results found matching the imposed criteria.
    • Notes Pane - displays various notes added and is specific for the selected view.
    • Notifications Pane - displays a list with all the notifications that appeared while authoring the package. Also, notifications about synchronized folders will be displayed when loading the project.

The Installation menu

This menu contains grouped links to all available installation pages. The pages unavailable in the current project appear disabled. The currently selected page is marked with a bullet. Clicking on an item will bring up the corresponding page.

The Project menu

  • Build - creates the Windows Installer package.
  • Run - launches the current project. If the project is not already built, this option will first build the project and then run the generated package.
  • Run and Log - launches the current project in logging mode. If the project is not already built, this option will first build the project and then run the generated package.
  • Run in VM - test the installation by running it in a provisioned virtual machine.
  • Open Output Folder - a Windows Explorer window will open at the location where the project is saved and where the MSI package will be build.
  • Options... - allows setting the project options from the Project Paths Tab.
  • Convert Paths... - converts the absolute project paths to path variables based paths.
  • Find - this dialog allows you to customize the search criteria. The search is made globally(the entire project) and it is possible to add more tables to the search.

The Wizard menu

  • Detect MSM - this wizard allows you to automatically replace resources (files and registry) from your project with a merge module that contanis them.
  • Convert Paths... - this wizard scans your installation project for static paths and changes them to path variables, which makes your project more easily portable. Alternatively the wizard allows you to transform project paths that already use path variables, to absolute.
  • Create Transform... - this wizard allows you to create a Windows Installer Transform file (MST).
  • Add Adobe Plug-in

Options

  • External Tools... - allows you to configure additional tools used during the build process through the External Tools dialog.
  • Auto Import... - allows you to configure the extensions used when importing XML and INI files.
  • Repository Manager... - manage dialogs or prerequisites in the Advanced Installer repository.
  • Repackager settings... - allows you to configure installation capture profiles for Advanced Repackager.
  • Package Validation... - allows you to configure the parameters for the ICE Validation process.
  • SCCM Configurations... - allows you to define the settings based on which the System Center Configuration Manager (SCCM) configuration file will be created.
  • Path Variables... - allows you to configure the path variables. The dialog will display all the global path variables defined and allows to manage your own path variables.
  • Auto Updates... - allows you to configure Advanced Installer's update process through the "Update Options" dialog.
  • Customer Experience Program... - allows you select if you want or not to help improve Advanced Installer by sending non-personal information on how it is being used.

The Help menu

  • Contents - displays the Advanced Installer User Guide.
  • Context Help - displays a help page for the current view in your project (it is a context sensitive help).
  • Support Forums - opens in the default browser the web page of the Advanced Installer forum.
  • Purchase Now - opens the web page where you can buy an Advanced Installer license.
  • Register... - allows you to introduce the registration code you received when you bought Advanced Installer. After that a license will be downloaded and installed on your machine.
  • About... - displays general information about Advanced Installer, like version, license, etc. and checks for updates.

Topics